[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 1/8] tests/9pfs: simplify fs_mkdir()
From: |
Greg Kurz |
Subject: |
Re: [PATCH 1/8] tests/9pfs: simplify fs_mkdir() |
Date: |
Tue, 20 Oct 2020 15:59:36 +0200 |
On Tue, 20 Oct 2020 15:43:21 +0200
Christian Schoenebeck <qemu_oss@crudebyte.com> wrote:
> On Dienstag, 20. Oktober 2020 15:35:36 CEST Greg Kurz wrote:
> > On Tue, 20 Oct 2020 01:13:23 +0200
> >
> > Christian Schoenebeck <qemu_oss@crudebyte.com> wrote:
> > > Split out walking a directory path to a separate new utility function
> > > fs_walk_fid() and use that function in fs_mkdir().
> > >
> > > The code difference saved this way is not much, but we'll use that new
> > > fs_walk_fid() function in the upcoming patches, so it will avoid quite
> > > some code duplication after all.
> > >
> > > Signed-off-by: Christian Schoenebeck <qemu_oss@crudebyte.com>
> > > ---
> > >
> > > tests/qtest/virtio-9p-test.c | 23 ++++++++++++++++++-----
> > > 1 file changed, 18 insertions(+), 5 deletions(-)
> > >
> > > diff --git a/tests/qtest/virtio-9p-test.c b/tests/qtest/virtio-9p-test.c
> > > index c15908f27b..dc724bbb1e 100644
> > > --- a/tests/qtest/virtio-9p-test.c
> > > +++ b/tests/qtest/virtio-9p-test.c
> > > @@ -967,13 +967,12 @@ static void fs_flush_ignored(void *obj, void *data,
> > > QGuestAllocator *t_alloc)>
> > > g_free(wnames[0]);
> > >
> > > }
> > >
> > > -static void fs_mkdir(void *obj, void *data, QGuestAllocator *t_alloc,
> > > - const char *path, const char *cname)
> > > +/* utility function: walk to requested dir and return fid for that dir */
> > > +static uint32_t fs_walk_fid(void *obj, void *data, QGuestAllocator
> > > *t_alloc, + const char *path)
> > >
> > > {
> >
> > Since fs_walk_fid() is a helper function, ie. not passed to qos_add_test(),
> > any reason to keep the "void *obj, void *data, QGuestAllocator *t_alloc"
> > based signature ? data and t_alloc aren't used at all and it seems that the
> > function should rather take a QVirtio9P * directly instead of casting from
> > a void *.
> >
> > Something like:
> >
> > static uint32_t fs_walk_fid(QVirtio9P *v9p, const char *path)
> > {
> > ...
> > }
> >
> >
> > Same remark applies to fs_mkdir() which isn't a top level test function
> > either BTW (sorry for not having spotted this earlier).
>
> Good point. Typical case of being copy & waste induced. I'll change that.
>
Well I guess I haven't set a good exemple by calling fs_attach() everywhere
instead of factoring out an helper in the first place... I have some spare
time, I'll fix that.
> Best regards,
> Christian Schoenebeck
>
>
- [PATCH 0/8] 9pfs: more local tests, Christian Schoenebeck, 2020/10/19
- [PATCH 1/8] tests/9pfs: simplify fs_mkdir(), Christian Schoenebeck, 2020/10/19
- [PATCH 2/8] tests/9pfs: add local unlinkat directory test, Christian Schoenebeck, 2020/10/19
- [PATCH 3/8] tests/9pfs: add local Tlcreate test, Christian Schoenebeck, 2020/10/19
- [PATCH 4/8] tests/9pfs: add local unlinkat file test, Christian Schoenebeck, 2020/10/19
- [PATCH 5/8] tests/9pfs: add local Tsymlink test, Christian Schoenebeck, 2020/10/19
- [PATCH 6/8] tests/9pfs: add local unlinkat symlink test, Christian Schoenebeck, 2020/10/19
- [PATCH 7/8] tests/9pfs: add local Tlink test, Christian Schoenebeck, 2020/10/19
- [PATCH 8/8] tests/9pfs: add local unlinkat hard link test, Christian Schoenebeck, 2020/10/19