[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH] migration: rename migration_bitmap_sync_range t
From: |
Dr. David Alan Gilbert |
Subject: |
Re: [Qemu-devel] [PATCH] migration: rename migration_bitmap_sync_range to ramblock_sync_dirty_bitmap |
Date: |
Wed, 7 Aug 2019 18:49:48 +0100 |
User-agent: |
Mutt/1.12.1 (2019-06-15) |
* Wei Yang (address@hidden) wrote:
> Rename for better understanding of the code.
>
> Suggested-by: Paolo Bonzini <address@hidden>
> Signed-off-by: Wei Yang <address@hidden>
this needs fixing after 'just pass RAMBlock is enough'
Dave
> ---
> migration/ram.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/migration/ram.c b/migration/ram.c
> index c5f9f4b0ef..66792568e2 100644
> --- a/migration/ram.c
> +++ b/migration/ram.c
> @@ -1669,7 +1669,7 @@ static inline bool
> migration_bitmap_clear_dirty(RAMState *rs,
> return ret;
> }
>
> -static void migration_bitmap_sync_range(RAMState *rs, RAMBlock *rb,
> +static void ramblock_sync_dirty_bitmap(RAMState *rs, RAMBlock *rb,
> ram_addr_t length)
> {
> rs->migration_dirty_pages +=
> @@ -1762,7 +1762,7 @@ static void migration_bitmap_sync(RAMState *rs)
> qemu_mutex_lock(&rs->bitmap_mutex);
> rcu_read_lock();
> RAMBLOCK_FOREACH_NOT_IGNORED(block) {
> - migration_bitmap_sync_range(rs, block, block->used_length);
> + ramblock_sync_dirty_bitmap(rs, block, block->used_length);
> }
> ram_counters.remaining = ram_bytes_remaining();
> rcu_read_unlock();
> @@ -4175,7 +4175,7 @@ static void colo_flush_ram_cache(void)
> memory_global_dirty_log_sync();
> rcu_read_lock();
> RAMBLOCK_FOREACH_NOT_IGNORED(block) {
> - migration_bitmap_sync_range(ram_state, block, block->used_length);
> + ramblock_sync_dirty_bitmap(ram_state, block, block->used_length);
> }
> rcu_read_unlock();
>
> --
> 2.17.1
>
>
--
Dr. David Alan Gilbert / address@hidden / Manchester, UK
- Re: [Qemu-devel] [PATCH] migration: rename migration_bitmap_sync_range to ramblock_sync_dirty_bitmap,
Dr. David Alan Gilbert <=