qemu-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-commits] [qemu/qemu] 2ab2ef: cmd646: Remove unused variable


From: GitHub
Subject: [Qemu-commits] [qemu/qemu] 2ab2ef: cmd646: Remove unused variable
Date: Mon, 28 Jan 2019 07:27:05 -0800

  Branch: refs/heads/master
  Home:   https://github.com/qemu/qemu
  Commit: 2ab2ef078504c9a4979bd5c457fdf5903292e0f7
      
https://github.com/qemu/qemu/commit/2ab2ef078504c9a4979bd5c457fdf5903292e0f7
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/cmd646.c
    M include/hw/ide/pci.h

  Log Message:
  -----------
  cmd646: Remove unused variable

There was a pointer to PCIIDEState in CMD646BAR which was set but
not used afterwards. Get rid of this unused variable.

Signed-off-by: BALATON Zoltan <address@hidden>
Tested-by: Mark Cave-Ayland <address@hidden>
Reviewed-by: John Snow <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: e210ec87b93cf94212b5f522d514115dc3604975
      
https://github.com/qemu/qemu/commit/e210ec87b93cf94212b5f522d514115dc3604975
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/cmd646.c
    M include/hw/ide/pci.h

  Log Message:
  -----------
  cmd646: Remove IDEBus from CMD646BAR

The cmd646 io mem ops callbacks only need the IDEBus which is
currently passed via a CMD646BAR struct. No need to wrap it up like
that, we can pass it directly to these callbacks which then allows to
drop the IDEBus from the CMD646BAR.

Signed-off-by: BALATON Zoltan <address@hidden>
Tested-by: Mark Cave-Ayland <address@hidden>
Reviewed-by: John Snow <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: c9ebc75dc24f99e881414e7f35544041f678235a
      
https://github.com/qemu/qemu/commit/c9ebc75dc24f99e881414e7f35544041f678235a
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/cmd646.c
    M hw/ide/pci.c
    M include/hw/ide/pci.h

  Log Message:
  -----------
  cmd646: Move PCI IDE specific functions to ide/pci.c

The io mem ops callbacks are not specific to CMD646 but really follow
the PCI IDE spec so move these from cmd646.c to pci.c to allow other
PCI IDE implementations to use them.

Signed-off-by: BALATON Zoltan <address@hidden>
Tested-by: Mark Cave-Ayland <address@hidden>
Reviewed-by: John Snow <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 8ac98d1a97a7aeefe45f4a5af37d61caa41ded54
      
https://github.com/qemu/qemu/commit/8ac98d1a97a7aeefe45f4a5af37d61caa41ded54
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/cmd646.c
    M include/hw/ide/pci.h

  Log Message:
  -----------
  ide: Get rid of CMD646BAR struct

Now that no CMD646 specific parts are left in CMD646BAR (all remaining
members are really PCI IDE specific) this struct can be deleted moving
the memory regions for PCI IDE BARs to PCIIDEState where they better
belong. The CMD646 PCI IDE model is adjusted accordingly.

Signed-off-by: BALATON Zoltan <address@hidden>
Tested-by: Mark Cave-Ayland <address@hidden>
Reviewed-by: John Snow <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 4eefdf7c1baa41e59cf4792df887a033e86339db
      
https://github.com/qemu/qemu/commit/4eefdf7c1baa41e59cf4792df887a033e86339db
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/sii3112.c

  Log Message:
  -----------
  sii3112: Remove duplicated code and use PCI IDE ops instead

Parts of the SiI3112 mmio are identical to PCI IDE registers so we can
use the corresponding functions that were factored out into ide/pci.c.
This removes code duplication and simplifies the SiI3112 model which
also helped to spot a copy paste error where reading status of the
2nd channel read the 1st channel instead. This is also fixed here.

Signed-off-by: BALATON Zoltan <address@hidden>
Tested-by: Mark Cave-Ayland <address@hidden>
Reviewed-by: John Snow <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 0252e66c5a577e80ba353f3048a681c4e5ab2ddd
      
https://github.com/qemu/qemu/commit/0252e66c5a577e80ba353f3048a681c4e5ab2ddd
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/via.c

  Log Message:
  -----------
  ide/via: Remove vt82c686b_init_ports() function

This function is only called once from vt82c686b_ide_realize() and its
content is simple enough to not need a separate function but be
included in realize directly (as done in other IDE models except PIIX
currently).

Signed-off-by: BALATON Zoltan <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 7dd687ba1b99009d31235d75c082279715dbf676
      
https://github.com/qemu/qemu/commit/7dd687ba1b99009d31235d75c082279715dbf676
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/via.c
    M hw/mips/mips_fulong2e.c
    M include/hw/ide.h

  Log Message:
  -----------
  ide/via: Rename functions to match device name

The device is called via-ide and the modelled IDE controller is not
specific to 82C686B but is also usable independently. Therefore, change
function name prefixes accordingly to match device name.

Signed-off-by: BALATON Zoltan <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 4ea98d317eb442c738f898f16cfdd47a18b7ca49
      
https://github.com/qemu/qemu/commit/4ea98d317eb442c738f898f16cfdd47a18b7ca49
  Author: BALATON Zoltan <address@hidden>
  Date:   2019-01-25 (Fri, 25 Jan 2019)

  Changed paths:
    M hw/ide/via.c

  Log Message:
  -----------
  ide/via: Implement and use native PCI IDE mode

This device only implemented ISA compatibility mode and native PCI IDE
mode was missing but no clients actually need ISA mode but to the
contrary, they usually want to switch to and use device in native
PCI IDE mode. Therefore implement native PCI mode and switch default
to that.

Signed-off-by: BALATON Zoltan <address@hidden>
Message-id: address@hidden
Signed-off-by: John Snow <address@hidden>


  Commit: 5f39a91dbd9a186edb999afd4d17524f4b1da14f
      
https://github.com/qemu/qemu/commit/5f39a91dbd9a186edb999afd4d17524f4b1da14f
  Author: Peter Maydell <address@hidden>
  Date:   2019-01-28 (Mon, 28 Jan 2019)

  Changed paths:
    M hw/ide/cmd646.c
    M hw/ide/pci.c
    M hw/ide/sii3112.c
    M hw/ide/via.c
    M hw/mips/mips_fulong2e.c
    M include/hw/ide.h
    M include/hw/ide/pci.h

  Log Message:
  -----------
  Merge remote-tracking branch 'remotes/jnsnow/tags/ide-pull-request' into 
staging

Pull request

# gpg: Signature made Fri 25 Jan 2019 22:06:08 GMT
# gpg:                using RSA key 7DEF8106AAFC390E
# gpg: Good signature from "John Snow (John Huston) <address@hidden>" [full]
# Primary key fingerprint: FAEB 9711 A12C F475 812F  18F2 88A9 064D 1835 61EB
#      Subkey fingerprint: F9B7 ABDB BCAC DF95 BE76  CBD0 7DEF 8106 AAFC 390E

* remotes/jnsnow/tags/ide-pull-request:
  ide/via: Implement and use native PCI IDE mode
  ide/via: Rename functions to match device name
  ide/via: Remove vt82c686b_init_ports() function
  sii3112: Remove duplicated code and use PCI IDE ops instead
  ide: Get rid of CMD646BAR struct
  cmd646: Move PCI IDE specific functions to ide/pci.c
  cmd646: Remove IDEBus from CMD646BAR
  cmd646: Remove unused variable

Signed-off-by: Peter Maydell <address@hidden>


Compare: https://github.com/qemu/qemu/compare/ad7a21e81231...5f39a91dbd9a
      **NOTE:** GitHub Services has been marked for deprecation: 
https://developer.github.com/changes/2018-04-25-github-services-deprecation/

      We will provide an alternative path for the email notifications by 
January 31st, 2019.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]