[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 11/15] acpi/ghes: better name GHES memory error function
From: |
Jonathan Cameron |
Subject: |
Re: [PATCH 11/15] acpi/ghes: better name GHES memory error function |
Date: |
Thu, 26 Sep 2024 13:07:54 +0100 |
On Wed, 25 Sep 2024 06:04:16 +0200
Mauro Carvalho Chehab <mchehab+huawei@kernel.org> wrote:
> The current function used to generate GHES data is specific for
> memory errors. Give a better name for it, as we now have a generic
> function as well.
>
> Reviewed-by: Igor Mammedov <imammedo@redhat.com>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
In general fine, but question below on what looks to be an unrelated change.
Jonathan
> diff --git a/target/arm/kvm.c b/target/arm/kvm.c
> index 849e2e21b304..57192285fb96 100644
> --- a/target/arm/kvm.c
> +++ b/target/arm/kvm.c
> @@ -2373,7 +2373,8 @@ void kvm_arch_on_sigbus_vcpu(CPUState *c, int code,
> void *addr)
> */
> if (code == BUS_MCEERR_AR) {
> kvm_cpu_synchronize_state(c);
> - if (!acpi_ghes_record_errors(ACPI_HEST_SRC_ID_SEA, paddr)) {
> + if (!acpi_ghes_memory_errors(ARM_ACPI_HEST_SRC_ID_SYNC,
The parameter changes seems unconnected to rest of the patch... Maybe at least
mention it in the patch description.
I can't find the definition of ARM_ACPI_HEST_SRC_ID_SYNC either so where
did that come from?
> + paddr)) {
> kvm_inject_arm_sea(c);
> } else {
> error_report("failed to record the error");
- [PATCH 04/15] acpi/ghes: better handle source_id and notification, (continued)
- [PATCH 04/15] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 09/15] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 14/15] better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 15/15] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 11/15] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/09/25
- Re: [PATCH 11/15] acpi/ghes: better name GHES memory error function,
Jonathan Cameron <=
- [PATCH 02/15] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 13/15] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 10/15] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 08/15] acpi/ghes: Prepare to support multiple sources on ghes, Mauro Carvalho Chehab, 2024/09/25