[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 11/15] acpi/ghes: better name GHES memory error function
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH 11/15] acpi/ghes: better name GHES memory error function |
Date: |
Wed, 25 Sep 2024 06:04:16 +0200 |
The current function used to generate GHES data is specific for
memory errors. Give a better name for it, as we now have a generic
function as well.
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
---
hw/acpi/ghes-stub.c | 2 +-
hw/acpi/ghes.c | 2 +-
include/hw/acpi/ghes.h | 5 +++--
target/arm/kvm.c | 3 ++-
4 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/hw/acpi/ghes-stub.c b/hw/acpi/ghes-stub.c
index 2b64cbd2819a..7cec1812dad9 100644
--- a/hw/acpi/ghes-stub.c
+++ b/hw/acpi/ghes-stub.c
@@ -11,7 +11,7 @@
#include "qemu/osdep.h"
#include "hw/acpi/ghes.h"
-int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
+int acpi_ghes_memory_errors(uint16_t source_id, uint64_t physical_address)
{
return -1;
}
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index 900f1571bc97..3af1cd16d4d7 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -454,7 +454,7 @@ void ghes_record_cper_errors(const void *cper, size_t len,
return;
}
-int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
+int acpi_ghes_memory_errors(uint16_t source_id, uint64_t physical_address)
{
/* Memory Error Section Type */
const uint8_t guid[] =
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 1b988ac1e2f2..051a9322141f 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -81,15 +81,16 @@ void acpi_build_hest(GArray *table_data, GArray
*hardware_errors,
const char *oem_id, const char *oem_table_id);
void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
GArray *hardware_errors);
+int acpi_ghes_memory_errors(uint16_t source_id,
+ uint64_t error_physical_addr);
void ghes_record_cper_errors(const void *cper, size_t len,
uint16_t source_id, Error **errp);
-int acpi_ghes_record_errors(uint16_t source_id, uint64_t error_physical_addr);
/**
* acpi_ghes_present: Report whether ACPI GHES table is present
*
* Returns: true if the system has an ACPI GHES table and it is
- * safe to call acpi_ghes_record_errors() to record a memory error.
+ * safe to call acpi_ghes_memory_errors() to record a memory error.
*/
bool acpi_ghes_present(void);
#endif
diff --git a/target/arm/kvm.c b/target/arm/kvm.c
index 849e2e21b304..57192285fb96 100644
--- a/target/arm/kvm.c
+++ b/target/arm/kvm.c
@@ -2373,7 +2373,8 @@ void kvm_arch_on_sigbus_vcpu(CPUState *c, int code, void
*addr)
*/
if (code == BUS_MCEERR_AR) {
kvm_cpu_synchronize_state(c);
- if (!acpi_ghes_record_errors(ACPI_HEST_SRC_ID_SEA, paddr)) {
+ if (!acpi_ghes_memory_errors(ARM_ACPI_HEST_SRC_ID_SYNC,
+ paddr)) {
kvm_inject_arm_sea(c);
} else {
error_report("failed to record the error");
--
2.46.1
- Re: [PATCH 07/15] acpi/ghes: Change the type for source_id, (continued)
- [PATCH 04/15] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 09/15] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 14/15] better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 15/15] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 11/15] acpi/ghes: better name GHES memory error function,
Mauro Carvalho Chehab <=
- [PATCH 02/15] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 13/15] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 10/15] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/09/25
- [PATCH 08/15] acpi/ghes: Prepare to support multiple sources on ghes, Mauro Carvalho Chehab, 2024/09/25