[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v3 03/15] target/arm: Do not use aarch64_sve_zcr_get_valid_le
From: |
Peter Maydell |
Subject: |
Re: [PATCH v3 03/15] target/arm: Do not use aarch64_sve_zcr_get_valid_len in reset |
Date: |
Tue, 31 May 2022 13:15:58 +0100 |
On Fri, 27 May 2022 at 19:07, Richard Henderson
<richard.henderson@linaro.org> wrote:
>
> We don't need to constrain the value set in zcr_el[1],
> because it will be done by sve_zcr_len_for_el.
>
> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
> ---
> target/arm/cpu.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/target/arm/cpu.c b/target/arm/cpu.c
> index d2bd74c2ed..0621944167 100644
> --- a/target/arm/cpu.c
> +++ b/target/arm/cpu.c
> @@ -208,8 +208,7 @@ static void arm_cpu_reset(DeviceState *dev)
> CPACR_EL1, ZEN, 3);
> /* with reasonable vector length */
> if (cpu_isar_feature(aa64_sve, cpu)) {
> - env->vfp.zcr_el[1] =
> - aarch64_sve_zcr_get_valid_len(cpu, cpu->sve_default_vq - 1);
> + env->vfp.zcr_el[1] = cpu->sve_default_vq - 1;
> }
I'm still not a fan of the zcr_el[] value not actually being
a valid one. I'd rather we constrained it when we write the
value into the field.
thanks
-- PMM
- [PATCH v3 00/15] target/arm: SME prep patches, Richard Henderson, 2022/05/27
- [PATCH v3 09/15] target/arm: Use el_is_in_host for sve_vqm1_for_el, Richard Henderson, 2022/05/27
- [PATCH v3 06/15] target/arm: Rename sve_zcr_len_for_el to sve_vqm1_for_el, Richard Henderson, 2022/05/27
- [PATCH v3 08/15] target/arm: Add el_is_in_host, Richard Henderson, 2022/05/27
- [PATCH v3 07/15] target/arm: Remove fp checks from sve_exception_el, Richard Henderson, 2022/05/27
- [PATCH v3 11/15] target/arm: Export sve contiguous ldst support functions, Richard Henderson, 2022/05/27