[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v3 09/15] target/arm: Use el_is_in_host for sve_vqm1_for_el
From: |
Richard Henderson |
Subject: |
[PATCH v3 09/15] target/arm: Use el_is_in_host for sve_vqm1_for_el |
Date: |
Fri, 27 May 2022 11:06:17 -0700 |
The ARM pseudocode function NVL uses this predicate now,
and I think it's a bit clearer. Simplify the pseudocode
condition by noting that IsInHost is always false for EL1.
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
target/arm/helper.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/target/arm/helper.c b/target/arm/helper.c
index d1b6c2459b..69b10be480 100644
--- a/target/arm/helper.c
+++ b/target/arm/helper.c
@@ -6230,8 +6230,7 @@ uint32_t sve_vqm1_for_el(CPUARMState *env, int el)
ARMCPU *cpu = env_archcpu(env);
uint32_t len = cpu->sve_max_vq - 1;
- if (el <= 1 &&
- (arm_hcr_el2_eff(env) & (HCR_E2H | HCR_TGE)) != (HCR_E2H | HCR_TGE)) {
+ if (el <= 1 && !el_is_in_host(env, el)) {
len = MIN(len, 0xf & (uint32_t)env->vfp.zcr_el[1]);
}
if (el <= 2 && arm_feature(env, ARM_FEATURE_EL2)) {
--
2.34.1
- [PATCH v3 00/15] target/arm: SME prep patches, Richard Henderson, 2022/05/27
- [PATCH v3 09/15] target/arm: Use el_is_in_host for sve_vqm1_for_el,
Richard Henderson <=
- [PATCH v3 06/15] target/arm: Rename sve_zcr_len_for_el to sve_vqm1_for_el, Richard Henderson, 2022/05/27
- [PATCH v3 08/15] target/arm: Add el_is_in_host, Richard Henderson, 2022/05/27
- [PATCH v3 07/15] target/arm: Remove fp checks from sve_exception_el, Richard Henderson, 2022/05/27
- [PATCH v3 11/15] target/arm: Export sve contiguous ldst support functions, Richard Henderson, 2022/05/27
- [PATCH v3 10/15] target/arm: Split out load/store primitives to sve_ldst_internal.h, Richard Henderson, 2022/05/27