[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Phpgroupware-users] Installation and Configuration Questions

From: Scott A. Henderson
Subject: RE: [Phpgroupware-users] Installation and Configuration Questions
Date: Fri, 12 Apr 2002 10:26:26 -0800

Having just gone through this recently I can pass on a little wisdom:

First of all look at the documentation on the phpgroupware site
(, this addresses the permission issue you are
running into.

Second if you are using the RC2 distribution there is problem with the
e-mail that will require you to do edit some source code see for the change that
needs to be made.  If you don't do this the e-mail won't work.

I didn't use the rpm package, but the tar ball and it went well you might
want to try and back out what you have and start over.  

I have moved the phpgroupware root to a number of locations.  As long as
your web server knows where to find it you should be ok, there is nothing
that I am aware of that ties this to a specific location.  With the rpm
version though if you move things around you will not be able to rpm -e the
app later.

As for your rpm installation, I am guessing that it went wrong.  If rpm -e
doesn't recognize the app then the database is not correct.  You can try
"rpm -q -a |grep php" or something like that to see if you can find it in
the database.  


-----Original Message-----
From: Phil Glaser [mailto:address@hidden
Sent: Friday, April 12, 2002 9:46 AM
To: address@hidden
Subject: [Phpgroupware-users] Installation and Configuration Questions


I have a couple of questions about installation and configuration.

First, I succeeded in bringing up the
as per the documentation. The setup page will not write for
me due to permissions. So I downloaded the file. The problem is ****** I
HAVE NO IDEA WHERE I SHOULD PUT *****. I tried puting in the
include path as per php.ini (/usr/share/php) to no avail. If only I knew
which directory to use, I would just set the permissions on it so apache
could write the file in the first place. I'm really stuck now on this one.

Second, I installed PhpGW from the latest RPM on sourceforge
(phpGroupWare-0.9.12-6.noarch.rpm). Everything seemed to go ok, in the sense
that the files installed under /home/httpd/html, but I received an error
message /templates/verdilak/;3cb6e765: cpio: MD5 sum mismatch.
Should I be worried about that? The other thing that makes me suspicious is
that when I then tried to do rpm -e on the package to uninstall it, RPM
thought it wasn't installed. So I'm concerned that the install didn't really

Third, as the RPM ran, it said it could not find user and group phpgroupware
and so used root instead (if I'd known I would have created them ahead of
time). To compensate I created the phpgroupware user and group and then
chown'd and chgrp'd everything under /home/httpd/html/phpgroupware to them.
Is this sufficient, or do I need to do anything else?

Fourth, if I want to put my document root somewhere else (apache default is
/var/www/html), can I just move phpgroupware directory tree there, or is RPM
doing anything else that would need to be changed. Alternatively, is there a
way to tell RPM where to install the files?

Many thanks for your help!!!

Phil Glaser

Phpgroupware-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]