[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Restarting Resin freezes monit

From: Martin Pala
Subject: Re: Restarting Resin freezes monit
Date: Tue, 21 Sep 2004 21:27:17 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040820 Debian/1.7.2-4


i have tried to replicate your problem but it works for me without problems. My configuration:

check apache with pidfile /var/run/
   start program = "/bin/su - apache -c '/etc/init.d/apache start'"
   stop program = "/bin/su - apache -c '/etc/init.d/apache stop'"
   if failed host localhost
      port 80 protocol http
      and request "/test"
      with checksum ad38ebf120253979403a4d2dcbc0105b
      with timeout 30 seconds
      then restart

If i changed file 'test' by appending some string to it, monit detected the checksum failure and tried to restart apache. I'm running monit 4.4-beta5. Can you try it? You can find it at:

Btw. you can use native monit setuid like this (example from documentation):

  exec "/usr/local/tomcat/bin/" as uid nobody and gid nobody

Thanks :)


address@hidden wrote:
Hallo list,

i got a problem with restarting Resin (Application Server) with
        monit version 4.2.1.

in my .monitrc i configured follwing:

check media with pidfile /opt/resin/
        start program = "/usr/bin/su - gauss -c '/opt/resin/bin/
        stop program =  "/usr/bin/su - gauss -c '/opt/resin/bin/
        if failed host localhost
               port 80 protocol http
               and request "/media/monit.jsp"
               with checksum <xxx>
               with timeout 30 seconds
        then restart
        alert address@hidden

This runs fine, as long as the checksum succeeds, but if it fails monit

Im my monit.log i get this output:

'media' is running with pid 2324
'media' zombie check passed [status_flag=0000]
'media' check_process_state() passed.
'media' succeeded connecting to INET[localhost:80]
HTTP error: HTTP/1.1 404 Not Found
Event: 'media' failed protocol test [HTTP] at INET[localhost:80].
Trying to restart 'media'
Monitoring disabled -- service media
stop: (media) /usr/bin/su

After this monit doesnt log anymore, but the service is running.
If i try to enable media monitoring, the command succeeds but the
status tells me:

monit: cannot read status from the monit daemon

now i have to kill the monit process with -9.

Any ideas?

Mit freundlichen Grüßen / Best regards

Oliver Walter

Zentrale Informationsverarbeitung
Bosch Rexroth AG
The Drive & Control Company
Sandweg 45
D-97737 Gemünden-Langenprozelten
telefone: +49(0)9352-18-1862

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]