[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Listening problem

From: Carey M. Drake
Subject: Re: Listening problem
Date: Wed, 21 Jul 2004 14:34:42 -0400 (EDT)
User-agent: SquirrelMail/1.5.1 [CVS]

On Wed, July 21, 2004 2:22 pm, Vlada Macek said:
> Hi,
> several hours ago I used the monit web interface to start a service. I 
> clicked the button and browser was waiting for response. It lasted too 
> long (apcupsd was not connected to the UPS and stalled), I lost patience 
> and hit the Stop button. And since that moment the strange thing is 
> hapening. Even if I kill the monit daemon, wait for several hours and then
> restart, monit is unable to bind its http port for listening. Strace shows
> this:
> bind(7, {sin_family=AF_INET, sin_port=htons(81), 
> sin_addr=inet_addr("#.#.#.#")}}, 16) = -1 EADDRNOTAVAIL (Cannot assign
> requested address)
> Until this moment, all worked ok. Does anyone have a clue? Server is Linux
> x86 and for several reasons I'd like to manage this without reboot (which
> would correct this, I hope).

Have you tried 'netstat -apn | grep 81' to see if there is anything still bound 
to port 81?

> Thanks,
> Vlada
> -- To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]