[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: Re[4]: xlsread does not read a column

From: PhilipNienhuis
Subject: Re: Fwd: Re[4]: xlsread does not read a column
Date: Tue, 16 Aug 2016 07:51:57 -0700 (PDT)

PhilipNienhuis wrote
> PhilipNienhuis wrote
>> NJank wrote
>>> ---------- Forwarded message ----------
>>> From: "Светлана Стрельникова" <

>>> strelolist@

>>> >
>>> Date: Aug 5, 2016 10:57 PM
>>> Subject: Re[4]: xlsread does not read a column
>>> :
>>>> Actually, it worked correctly on my machine too, but a couple of days
>>>> ago
>>> it changed.
>>>> One morning it just started to behave like that (i did not turn off my
>>> computer the previous evening),
>>>> may be it was some windows update?
>>> <snip>
>> The developer did eye it, but while on vacation with patchy web access,
>> replying through nabble (my only option there) moved me to a fairly
>> suspicious Russian email site with loads of "404"-s so I couldn't answer.
>> Anyway I'll try to look at it this week. I did note something else in
>> Svetlana's reply that shouldn't happen anyway. Maybe I can reproduce her
>> xlsread issues along the way.
> I had a brief look.
> I can reproduce the OP's problem but only with the COM interface. Funny as
> Excel itself reads the file allright.

Svetlana, I think the only thing that changed is that you tried to read a
worksheet with just one column of data rather than several columns. That
triggered an obscure bug that must have been there for a looong time (many

To get rid of the bug:

1.  Type in the Octave terminal:
strrep (which ("oct2xls"), "oct2xls.m", ["private" filesep])
and note the location that is returned;

2.  please copy
(if reguired select "raw" in left column)
and put it in the location obtained in step 1.

The (easy) fix is already in the io package repo.

Thanks for reporting.


View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]