[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: install netcdf package

From: Clinton Winant
Subject: Re: install netcdf package
Date: Thu, 26 Nov 2015 10:27:28 -0800

Hi Dmitri

I just tried to install netcdf package for octave in a new computer, and got the following error:

make: Entering directory '/tmp/oct-z96xxP/netcdf/src'
/usr/bin/mkoctfile --verbose -DHAVE_OCTAVE_ -v -I/usr/local/netcdf/include -L/usr/local/netcdf/lib -lnetcdf
g++ -c -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/octave-4.0.0/octave/.. -I/usr/include/octave-4.0.0/octave -I/usr/include/hdf5/serial -I/usr/include/mpi -pthread -fopenmp -g -O2 -fstack-protector-strong -Wformat -Werror=format-security   -I/usr/local/netcdf/include  -DHAVE_OCTAVE_ -o __netcdf__.o
g++ -shared -Wl,-Bsymbolic  -o __netcdf__.oct  __netcdf__.o   -L/usr/local/netcdf/lib -lnetcdf -L/usr/lib/x86_64-linux-gnu/octave/4.0.0 -L/usr/lib/x86_64-linux-gnu -loctinterp -loctave -Wl,-Bsymbolic-functions -Wl,-z,relro 
make: Leaving directory '/tmp/oct-z96xxP/netcdf/src'
copyfile /tmp/oct-z96xxP/netcdf/src/__netcdf__.oct /tmp/oct-z96xxP/netcdf/inst/x86_64-pc-linux-gnu-api-v50+
/home/cdw/octave/netcdf-1.0.7/x86_64-pc-linux-gnu-api-v50+/__netcdf__.oct: failed to load: cannot open shared object file: No such file or directory
error: called from 'doc_cache_create>create_cache' in file /usr/share/octave/4.0.0/m/help/doc_cache_create.m near line 106, column 18
>> quit
warning: load_path: /home/cdw/octave/netcdf-1.0.7/x86_64-pc-linux-gnu-api-v50+: No such file or directory

address@hidden:~$ locate
address@hidden:~$ ls /usr/local/netcdf/lib
libnetcdf.a   libnetcdf.settings      pkgconfig

As you can see the missing library is in /usr/local/netcdf/lib  ????

machine:  hp z210, OS Ubuntu 15.10 Octave 4.4.4 

On Sat, Nov 21, 2015 at 7:03 PM, Dmitri A. Sergatskov <address@hidden> wrote:
On Sat, Nov 21, 2015 at 6:58 PM, Clinton Winant <address@hidden> wrote:
I have tried to install netcdf package following

I already have the netcdf installed and running on my machine:
ls /usr/local/netcdf/lib
libnetcdf.a  libnetcdff.a  libnetcdf.settings  pkgconfig

​I think you need to install shared libraries​.
Regardless you should tell us what kind of computer system do you have, how did you
install octave etc...

​FWIW netcdf installs fine on Fedora 23:

​octave:1> pkg load netcdf
octave:2> test_netcdf
Using NetCDF library version " of Aug 16 2015 15:07:34 $"
run test_netcdf_constant..............   OK  
run test_netcdf_create................   OK  
run test_netcdf_low_level_interface...   OK  
run test_netcdf_unlim.................   OK  
run test_netcdf_datatypes.............   OK  
run test_netcdf_scalar_variable.......   OK  
run test_netcdf_attributes............   OK  
run test_netcdf_high_level_interface..   OK  
run test_netcdf_ncwriteschema.........   OK  
run test_netcdf_ncwriteschema_unlim...   OK  
run test_netcdf_ncwriteschema_chunking   OK  
run test_netcdf_ncwriteschema_group...   OK  



reply via email to

[Prev in Thread] Current Thread [Next in Thread]