[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: dicom package does not recognize gdcm package (on which it is depend

From: Lennart Geurts
Subject: Re: dicom package does not recognize gdcm package (on which it is dependend)
Date: Sat, 14 Mar 2015 13:27:20 +0100

On 14 March 2015 at 13:26, Lennart Geurts <address@hidden> wrote:

On 13 March 2015 at 07:32, Andy Buckle <address@hidden> wrote:

On 12 March 2015 at 23:55, Lennart Geurts <address@hidden> wrote:

On 10 March 2015 at 20:55, Andy Buckle <address@hidden> wrote:

On 7 March 2015 at 14:31, Andy Buckle <address@hidden> wrote:

On 5 March 2015 at 10:55, Lennart Geurts <address@hidden> wrote:
Dear all,

This is the first time I use this mailing list, I hope I dont use it inappropriately. I have searched previous questions and found a similar problem from a user on OSx. However I run a Debian (Jessie) distribution and Im not sure how alike these are. I am from the medical imaging community and at the office I use a windows environment with matlab. At home I started using a linux environment and want to use octave, for which the dicom package is essential (my data is in the dicom format and not readily converted to nifti because of its high dimensionality, it would require many,many seperate files).

The dicom package is dependend on the gdcm library, which I have installed. The when installing the dicom package I get this error:

fatal error: gdcm-2.0/gdcmReader.h: No such file

The current gdcm version is newer than 2.0 so I thought maybe I should use the older version, but the error remained. Even the older function did not get installed to that path. I think the dicom package does not look at which path it should use.

Maybe this is a bug because the path is hardcoded (as suggested in the similar OSx thread)
Maybe this happens because the last release is from 2011 and the package is just not maintained anymore, while gdcm keeps getting updates.
Maybe Im just doing something horribly wrong that Im not seeing.

If anybody has some hints/ideas that would help a lot thanks!


I recently got the dicom package working on
debian 7.8
octave 3.8.2
gdcm2.2 (package name libgdcm2-dev)
up-to date (unreleased) dicom package
"download snapshot" from here

Carne made some automake magic, that I think will fix your issue.

cd dicom/src

you will need to get the resulting oct files (and the dic file) in octave's


/* andy buckle */

On 7 March 2015 at 11:15, Lennart Geurts <address@hidden> wrote:
Hi guys thanks a lot for your help.

I did have libgdcm2-dev installed (libgdcm2-dev is already the newest version. apt-get told me)

it now catches at this:
checking for GDCM... CMake Error: Problem processing arguments. Aborting.
CMake Error: Problem processing arguments. Aborting.
checking gdcmSystem.h usability... no
checking gdcmSystem.h presence... no
checking for gdcmSystem.h... no
configure: error: Unable to find GDCM headers (do you have CMake installed?)

I do have cmake and automake installed.

The way apt finds gdcm and the way cmake finds gdcm must be different. Somewhere in configure I read
 --find-package "-DNAME=GDCM"
Maybe I should replace GDCM with libgdcm2-dev?

(please bottom post)

I made a Debian Jessie RC1 install. I installed Octave 3.8.2 (standard in the repo for Jessie).

libgdcm2-dev gives you gdcm 2.4 on Jessie, whereas I get gdcm 2.2 from the same package name on wheezy.

This should not be a huge problem, as I have got the dicom package working on openSuSE with gdcm 2.4. It's some tricky file location thing that's the problem. Maybe it's just defeating automake, I don't know. I have run out of time for the moment.

/* andy buckle */

I made a Makefile that works for Debian Jessie with octave, gdcm etc from the standard repo. Find it attached. I left commented out the previous bits that work for openSuSE. I don't know what the correct way to get a universal install with automake is. I am really hoping someone chips in to help here.

you need the "liboctave-dev" package too, so mkoctfile is available outside octave.

put the attached Makefile in the dicom src directory, and from there just run make.

/* andy buckle */
Just tried it. Building the files did give some warnings about the octave path while still resulting in oct files. Then adding the location of the oct files to the octave path resulted in callable functions in octave. They work nicely, thanks a bunch! My data gets loaded just like in matlab now, perfect. The headers not yet, dicominfo crashed octave because it couldnt find a dictionary. But I think I can just get it from my matlab code.

The pkg file has a .dic file. just add it to your octave path. No need to use matlab's.

/* andy buckle */

Terrific, dicomread is working as well now. Thank you Andy!

Sorry I meant dicominfo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]