[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Redhat 7.0 and octave

From: John W. Eaton
Subject: Redhat 7.0 and octave
Date: Tue, 28 Nov 2000 19:48:25 -0600

On 29-Nov-2000, Phil Cummins <address@hidden> wrote:

|   I sent a message out about this before, when I was considering 
| installing RedHat 7.0 on my notebook PC. At that time Trond Eivind 
| Glomsrod said that octave 2.0.16 required a "compat compiler"
| (and they have supplied the appropriate rpm) but that 2.1.x
| compiles just fine.
|   I have now installed 7.0 on my notebook and gave 2.0.16 a 
| try. Indeed, it doesn't compile under the gcc-2.96-54 shipped
| with RedHat 7.0. It had many problems with function (member
| functions, I think) prototypes that didn't have argument types
| specified. I tried fixing a few of these, but there seemed 
| to be quite a few, and I don't know much C++. Since an rpm 
| exists I didn't pursue it further (what is the "compat compiler",
| anyway?).
|   I also thought it might be a good opportunity to switch to the 
| development tree, so I tried making 2.1.31. That chugged away for 
| quite a long time, even on my 750 MHz Pentium III, but finally 
| failed trying to compile Since I was on my notebook at 
| home I don't have the exact error message, but it was reported at 
| line 1095 (the end of, and complained that it couldn't 
| determine the end of the argument list to macro XDEFUN_LOAD (well, 
| I think XDEFUN_LOAD was the name of the macro). 
|   I'm sorry to say that I probably will not be able to pursue this
| much further, and will likely just install the 2.0.16 rpm. I just 
| thought people on the list might want to know about the problem. If 
| anyone has a suggestion that might resolve the compile problem with 
| 2.1.31 I'll give it a try and let you know what happens. Or perhaps
| no one else is running into problems with RedHat 7.0?

Sorry, I don't have any Red Hat 7.0 systems, and your description is
too vague for me to figure out what the problem is.

If you'd like to see this problem fixed, please submit a complete bug
report to address@hidden  If you are not sure what to
include in your report so that someone has a fighting chance of
actually fixing the problem, then please read first.



Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]