[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem using Octave and gnuplot in Windows

Subject: Re: Problem using Octave and gnuplot in Windows
Date: Sat, 15 May 1999 00:01:47 +0200

-----Ursprungligt meddelande-----
Från: John W. Eaton <address@hidden>
Till: ERIKSSON ANDERS <address@hidden>
Kopia: address@hidden <address@hidden>
Datum: den 12 maj 1999 19:43
Ämne: Problem using Octave and gnuplot in Windows

>On 20-Apr-1999, ERIKSSON ANDERS <address@hidden> wrote:
>| there seems to be a problem when running Octave 2.0.13 and  
>| gnuplot 3.7 on Windows'98.
>| The following command sequence works as it should:
>| octave>    a = rand (100,1)
>| octave>    a
>| Octave displays the column vector in browsing (less) mode and the Octave 
>| returns when I hit the q key.
>| However, the following sequence will cause Octave to hang:
>| octave>    a = rand (100,1)
>| octave>    gplot (a)
>| octave>    a
>| gnuplot works perfectly, but when the last command displays the "a" vector, 
>| and Octave goes into browsing mode, it will hang when I try to exit 
>| this mode.. The Octave prompt does not return, regardless how I try to quit 
>the browsing 
>| mode using the q key or ctrl-C. 
>| The problem seems to be related to the pipe-gnuplot process. If I kill this 
>| process after the gplot command, before going into the browsing mode, 
>| the browsing mode will work. 
>| Likewise, if I use the closeplot command after the gplot command, 
>| the browsing will work. But these work-arounds are rather inconvenient. 
>| Any suggestions for a solution?
>| I have made the installation according to the instructions in 
>| I use the following binaries:
>| octave-2.0.13-i386-pc-cygwin32
>| less-gnu-win32
>| pipe-gnuplot
>| cdk
>| They are all the current versions from
>So you are using the cygwin b19 library?  I wonder if this problem is
>solved by the b20 library.  Can anyone else who is using Octave on a
>Windows platform reproduce the bug, or confirm that it is not present
>with some other version of Windows (95, NT) or with a newer version of
>the cygwin libraries?
>I no longer have easy access to a system running any version of
>Windows, so I can't debug this problem.

So I installed cygwin b20.1 and now it works perfectly!
The problem I described above seems to be related to 
cygwin b19. 

Best regards

Anders Eriksson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]