[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

octave-2.0.14 installation problem on Solaris 2.5.1

From: John W. Eaton
Subject: octave-2.0.14 installation problem on Solaris 2.5.1
Date: Wed, 12 May 1999 01:41:09 -0500 (CDT)

On 12-May-1999, Eran Kishon <address@hidden> wrote:

| While trying to install octave-2.0.14 (first time) I receive the
| following error in 
| the "config.log" file:
| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
| configure:5479: checking for sys_siglist declaration in signal.h or
| unistd.h
| configure:5517: checking for sys_siglist variable
| configure:5526: gcc -o conftest -g -O2  -g conftest.c -ldl -lsocket -lm 
| 1>&5
| Undefined                     first referenced
|  symbol                           in file
| sys_siglist                         /var/tmp/cca0074a1.o
| ld: fatal: Symbol referencing errors. No output written to conftest
| configure: failed program was:
| #line 5519 "configure"
| #include "confdefs.h"
| #include <stdio.h>
| int main() {
| extern char *sys_siglist[]; printf ("%s\n", sys_siglist[1]);
| ; return 0; }
| configure:5542: checking for type of signal functions
| configure:5643: checking if signal handlers must be reinstalled when
| invoked
| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
| (I left on purpose 'good' results before and after the problem).

I don't see that this is a problem.  The configure script tried to
find a declaration for sys_siglist in signal.h or unistd.h but
failed.  Since it isn't declared in either of those files, the
declaration is handled in some other way.

| I tried to run 'make' inspite the sys_siglist problem but the
| compilation crashed
| (after a long time) with the following message:
| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
| gcc  -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -I../glob
| -I../glob -DHAVE_CONFIG_H -fno-rtti -fno-exceptions
| -fno-implicit-templates -g -O2 -Wall -rdynamic \
| -L..   -fPIC -g -o octave \
| octave.o builtins.o  balance.o  besselj.o  betainc.o  chol.o  colloc.o 
| dassl.o  det.o  eig.o  expm.o  fft.o  fft2.o  filter.o  find.o 
| fsolve.o  gammainc.o  getgrent.o  getpwent.o  getrusage.o  givens.o 
| hess.o  ifft.o  ifft2.o  inv.o  log.o  lpsolve.o  lsode.o  lu.o 
| minmax.o  pinv.o  qr.o  quad.o  qzval.o  rand.o  schur.o  sort.o  svd.o 
| syl.o  time.o \
| -L../liboctave -L../libcruft -L../src -Xlinker -R -Xlinker
| /disk2/opt/usr/local/lib/octave-2.0.14 \
| ../src/liboctinterp.a ../liboctave/liboctave.a  ../libcruft/libcruft.a 
| ../readline/libreadline.a ../kpathsea/libkpathsea.a ../glob/libglob.a  \
| -lg2c -lm  -L/usr/ccs/lib -L/usr/lib
| -L/disk2/opt/usr/local/lib/gcc-lib/sparc-sun-solaris2.5.1/2.8.1
| -L/disk2/opt/usr/local/sparc-sun-solaris2.5.1/lib -L/usr/ccs/bin
| -L/usr/ccs/lib -L/disk2/opt/usr/local/lib -lm -ll -lcurses -ldl -lsocket
| -lm 
| gcc: unrecognized option `-rdynamic'            
| !!!!!!!!!!!!!!!!!!!!!!!!!!!!1

That is not fatal.

| Undefined                     first referenced
|  symbol                           in file
| _vt.13strstreambase.3ios            ../src/liboctinterp.a(dirfns.o)
| cout                                octave.o
| scan__7istreamPCce                  ../src/liboctinterp.a(oct-stream.o)
| ../src/liboctinterp.a(input.o)
| sync__7filebuf                      ../src/liboctinterp.a(oct-procbuf.o)
| _vt.7istream.3ios                   ../src/liboctinterp.a(dirfns.o)

These are symbols that should be found in libstdc++.  That library is
not included in the final link command because Octave is supposed to
be linked by the C++ compiler (see the rule in src/Makefile), and the
C++ compiler should automatically add that library to the list.  You
have it being linked with `gcc' instead of `g++' though, so it looks
like CXX was somehow defined to be `gcc' somewhere along the way.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]