[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

octave-2.0.14 installation problem on Solaris 2.5.1

From: Eran Kishon
Subject: octave-2.0.14 installation problem on Solaris 2.5.1
Date: Wed, 12 May 1999 09:15:24 +0200

Hi all,

While trying to install octave-2.0.14 (first time) I receive the
following error in 
the "config.log" file:

configure:5479: checking for sys_siglist declaration in signal.h or
configure:5517: checking for sys_siglist variable
configure:5526: gcc -o conftest -g -O2  -g conftest.c -ldl -lsocket -lm 
Undefined                       first referenced
 symbol                             in file
sys_siglist                         /var/tmp/cca0074a1.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 5519 "configure"
#include "confdefs.h"
#include <stdio.h>
int main() {
extern char *sys_siglist[]; printf ("%s\n", sys_siglist[1]);
; return 0; }
configure:5542: checking for type of signal functions
configure:5643: checking if signal handlers must be reinstalled when

(I left on purpose 'good' results before and after the problem).

I tried to run 'make' inspite the sys_siglist problem but the
compilation crashed
(after a long time) with the following message:

gcc  -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -I../glob
-I../glob -DHAVE_CONFIG_H -fno-rtti -fno-exceptions
-fno-implicit-templates -g -O2 -Wall -rdynamic \
-L..   -fPIC -g -o octave \
octave.o builtins.o  balance.o  besselj.o  betainc.o  chol.o  colloc.o 
dassl.o  det.o  eig.o  expm.o  fft.o  fft2.o  filter.o  find.o 
fsolve.o  gammainc.o  getgrent.o  getpwent.o  getrusage.o  givens.o 
hess.o  ifft.o  ifft2.o  inv.o  log.o  lpsolve.o  lsode.o  lu.o 
minmax.o  pinv.o  qr.o  quad.o  qzval.o  rand.o  schur.o  sort.o  svd.o 
syl.o  time.o \
-L../liboctave -L../libcruft -L../src -Xlinker -R -Xlinker
/disk2/opt/usr/local/lib/octave-2.0.14 \
../src/liboctinterp.a ../liboctave/liboctave.a  ../libcruft/libcruft.a 
../readline/libreadline.a ../kpathsea/libkpathsea.a ../glob/libglob.a  \
-lg2c -lm  -L/usr/ccs/lib -L/usr/lib
-L/disk2/opt/usr/local/sparc-sun-solaris2.5.1/lib -L/usr/ccs/bin
-L/usr/ccs/lib -L/disk2/opt/usr/local/lib -lm -ll -lcurses -ldl -lsocket
gcc: unrecognized option `-rdynamic'            
Undefined                       first referenced
 symbol                             in file
_vt.13strstreambase.3ios            ../src/liboctinterp.a(dirfns.o)
cout                                octave.o
scan__7istreamPCce                  ../src/liboctinterp.a(oct-stream.o)
sync__7filebuf                      ../src/liboctinterp.a(oct-procbuf.o)
_vt.7istream.3ios                   ../src/liboctinterp.a(dirfns.o)

My platform is a SUN sparcstation running solaris 2.5.1.
I use gcc 2.8.1 (built with g77).
I ran a ./configure using only the --prefix option.

Does anyone have a clue ???
(Please Email to me directly since I am still not on the mailing list)

Eran Kishon - NOGATECH (Israel)
Email: address@hidden
Tel: 972-9-7644860 (4045)
Fax: 972-9-7644870

reply via email to

[Prev in Thread] Current Thread [Next in Thread]