[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

using Solaris binaries

From: Mike Miller
Subject: using Solaris binaries
Date: Thu, 18 Mar 1999 00:28:22 -0600 (CST)

I installed Octave, version 2.0.13 (sparc-sun-solaris2.5 binaries) on my
Sun Ultra 2 2200 running Solaris 2.6.  When the installation was complete,
I tried to run octave and received an error stating that could
not be found. I checked the help-octave archive and found that this
problem came up just a few days ago for another user.  I was able to fix
the problem as follows.

Apparently, the package SUNWspro was available on the machine on which
octave was compiled, so octave looks for certain libraries from that
package.  The package, which includes a FORTRAN compiler, is available
from Sun under a 30-day "Try-It and Buy-It" option at

After 30 days, the compiler will no longer function, but the libraries are
still available and it seems that Sun has no objection to their continued
use.  Thus, this is a free permanent fix.  Unfortunately, to get the few
files I needed, I downloaded 13 tar files, a total of 292 megabytes!

After installing the whopping package (it went very smoothly), I started
up octave and it ran beautifully.  I then tried it on a second machine.
This time I only copied over the file and placed it in an
appropriate place (see below).  Octave then stated that
was missing, so I copied that file over.   Then it was missing,
so I copied that one over.  After that, octave ran fine.  So it seems like
the three files that are needed are these three files:


With those present on the system, octave runs.



Michael B. Miller, M.S., Ph.D., M.P.E.
Department of Psychology
210 McAlester Hall
University of Missouri--Columbia
Columbia, MO 65211
 Phone: (573) 882-5671
   Fax: (573) 882-7710
e-mail: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]