[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mach kernel boot messages & pfinet configuration

From: Grant Bowman
Subject: mach kernel boot messages & pfinet configuration
Date: Mon, 22 Apr 2002 04:17:29 -0700
User-agent: Mutt/1.1.11i

Hi everyone.  After fiddling with the Hurd a few years ago and giving 
up I made a new install recently.  I decided to do so after upgrading 
my Debian bootloader from Lilo to Grub and figured I would give the
GNU/Debian Hurd port and the Mach microkernel another chance.  Seems to
boot fine, glad to see work still moving forward.

However I am frusrated since I'm having a problem with getting my
network card set up.  Without the network I can't run apt-get & dselect.
The loopback device works fine.  When I run the commands described at
specifically 'settrans -fgap /servers/socket/2 /hurd/pfinet -i eth0 -a -g -m' since I am behind a small
NAT router and a cable modem all I get is the following output:

/hurd/pfinet: eth0 (os/device) no such device
settrans: /hurd/pfinet: translator died

I'm also having a problem -getting- the text of the kernel "dmesg" so
that I can find out more about what the Mach sees of my hardware.  I'm
assuming my next step is to compile a new kernel but I can't see if the
devices I need are already in the stock kernel since I think they scroll
by too fast.

* Some of the boot messages scroll off the screen too fast for me to
  see.  First I can see everything down to the checking of the IDE
  drives.  Then there's a section I never see (too fast), then the
  parallel port probing, SCSI probing, 3c59x probing, then the comm
  ports initialize, then come the multiboot modules specified from the
  grub menu.lst file.  
  Not specifying the modules in menu.lst (editing the menu.lst default
  during boot and deleting them) allows me to read a portion of the
  messages I couldn't see before at the expense of having the kernel
  panic and reboot after 30 seconds or so.  At least I could read some
  more of the messages but not all of them.  I still can't see the
  section between the IDE drives and the parallel port probing.

* /boot/servers.boot gives files to run by /boot/serverboot.gz, but
  I can't find where to pass the -d argument to the serverboot program
  described in /info/, node: Invoking serverboot.  This
  would give a pause (hopefully somewhere useful) until a key is
  pressed.  I've tried passing it via the kernel line of my menu.lst
  file (both before and after the root= argument) but it won't work.

* Putting /bin/sleep commands in both /libexec/rc and /libexec/runsystem
  are too late in the boot process to help much but they do help a

* there's no facility like the linux dmesg writing to /var/log/dmesg
  that I can find.

* The Pause/Break key doesn't seem to stop anything

* The BIOS detects the card at IRQ 10, isapnp under Linux shows this:

  # Card 1: (serial identifier 2a 02 8c d9 c8 01 22 8b 11)
  # Vendor Id DLK2201, Serial Number 42785224, checksum 0x2A.
  # Version 1.0, Vendor version 0.0
  # ANSI string -->D-Link DE-220P PnP ISA Card<--

Any help you can provide would be most appreciated.

-- Grant Bowman                                <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]