[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Comparable syslinux kernel command in GRUB2?

From: Robert LeBlanc
Subject: Comparable syslinux kernel command in GRUB2?
Date: Sun, 13 Mar 2022 10:17:34 -0600

I'm trying to convert a syslinux/isolinux config from the VMware ESXi installer ISO for PXE booting and I'm trying to figure out how the syslinux 'kernel' command translates to GRUB2. I've tried `linux` and `linux16`, but those don't work. I've found some examples of using `multiboot`, but that just hangs. I tried chainloading the ISO as well as the `syslinux_source` and `syslinux_configfile` (which is not the way I'd like to go in the end) but it also fails with a message "kernel without label" when I load the isolinux.bin file with syslinux_source.

At this point I'm trying to understand how "kernel" in syslinux is able to load the ESXi kernel, but GRUB is not. This is the first thing that I can't get GRUB to do so I'm assuming it's an issue with me and I need more enlightenment. This is the ESXi 6.7 ISO that I'm working with.

Thank you.
Robert LeBlanc
PGP Fingerprint 79A2 9CA4 6CC4 45DD A904  C70E E654 3BB2 FA62 B9F1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]