[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Comparable syslinux kernel command in GRUB2?

From: Daniel Kiper
Subject: Re: Comparable syslinux kernel command in GRUB2?
Date: Thu, 17 Mar 2022 23:33:42 +0100
User-agent: NeoMutt/20170113 (1.7.2)

Hi Robert,

First of all, sorry for late reply...

On Sun, Mar 13, 2022 at 10:17:34AM -0600, Robert LeBlanc wrote:
> I'm trying to convert a syslinux/isolinux config from the VMware ESXi 
> installer
> ISO for PXE booting and I'm trying to figure out how the syslinux 'kernel'
> command translates to GRUB2. I've tried `linux` and `linux16`, but those don't
> work. I've found some examples of using `multiboot`, but that just hangs. I
> tried chainloading the ISO as well as the `syslinux_source` and
> `syslinux_configfile` (which is not the way I'd like to go in the end) but it
> also fails with a message "kernel without label" when I load the isolinux.bin
> file with syslinux_source.
> At this point I'm trying to understand how "kernel" in syslinux is able to 
> load
> the ESXi kernel, but GRUB is not. This is the first thing that I can't get 
> to do so I'm assuming it's an issue with me and I need more enlightenment. 
> This
> is the ESXi 6.7 ISO that I'm working with.

Could you provide more info about the version of GRUB which you are
using and type of system on which you are trying to run it? Is it UEFI
or legacy BIOS machine?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]