[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] Re: 32bit GCL

From: George W. Dinolt
Subject: Re: [Gcl-devel] Re: 32bit GCL
Date: Fri, 06 Aug 2010 15:49:27 -0700
User-agent: Mozilla/5.0 (X11; U; FreeBSD amd64; en-US; rv: Gecko/20100806 Thunderbird/3.1.2 ThunderBrowse/3.3.1


I had the same problem. The issue seems to be connected with having tcl/tk in your path. When that happens, gcl tries to link them in and the issue you discovered raises its head. If you remove /opt/local/bin or /sw/bin/ or wherever you have tcl/tk installed from your path, then gcl (32bit) builds and runs beautifully on OS X 10.5.8. I have been able to build both acl2 and open-axiom. Acl2 runs through all the books except defxdoc on my systems. Open-axiom seems to be having trouble with the graphics but otherwise works well.

I had the same problem building gcl 64 bit on OS X. Again removing, in my case /opt/local/bin from the path and building, worked fine. ACL2 built, but open-axiom did not build. Error report to come.


On 08/06/10 14:32, Gabriel Dos Reis wrote:
Matt Kaufmann<address@hidden>  writes:

| Hi, Camm --
| I've just grabbed the latest cvs version of GCL 2.6.8pre and built
| ACL2 with it, on my Intel Mac running Mac OS 10.6.4.  The build
| succeeded, as did a run of the ACL2 regression suite (using a
| development copy of ACL2, not much different from ACL2 4.0) -- well,
| almost.  (But almost is still great -- thanks!)  Here's the story.

I'm slightly less lucky.  I just tried a build on dawring 9.8.0:  It
failed with

    >gcc  -c -m32  -Wall -DVOL=volatile -fsigned-char -pipe -O3 
-fomit-frame-pointer  -I/Users/gdr/sandbox/gcl-2.6.8.cvs/o -I../o -I../h 
-I/opt/local/lib/../include -I/opt/local/lib/../include guis.c
    guis.c: In function ‘main’:
    guis.c:293: error: too many arguments to function ‘setpgrp’
    make[1]: *** [guis.o] Error 1
    make: *** [do-gcl-tk] Error 2

    real  4m57.520s
    user  3m49.066s
    sys   1m5.671s
    ring:gcl-2.6.8.cvs gdr$ uname -a
    Darwin ring.cs.tamu.edu 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 
16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Do I need special config flags?

-- Gaby

Gcl-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]