[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] :noweb-ref property inheritance failure?

From: D Bro
Subject: Re: [O] :noweb-ref property inheritance failure?
Date: Tue, 18 Apr 2017 21:53:23 -0500

PS  I verified that in addition to org-use-property-inheritance, I have org-babel-use-quick-and-dirty-noweb-expansion set to nil, since the documentation and mailing list indicate that’s not compatible with property inheritance.

It’s good (and bad :) to know it’s just my config, based on it working for you…

On Apr 18, 2017, at 9:47 PM, D Bro <address@hidden> wrote:

Many thanks—especially for the quick response.  Unfortunately, no go.

  1. The headline was a copy and paste issue into the email — my org-lint only complains about the :classname (I didn’t even know about org-lint, thank you!)
  2. Export to Ascii produces:

1 Create

  | <<testdemo2>>

1.1 Let's see what our code-weaving produces

1.1.1 this is how we will assemble our code:

  | public class Yo {
  |   public static void main (Args[]) {

1.1.2 body

  | return "The test worked!";

1.1.3 foot

  | // <<test-foot>>
  | }}

1.1.4 weave together

  - which will weave together the above blocks to produce this:

    | cat TestDemo2.java


On Apr 18, 2017, at 9:04 PM, Charles C. Berry <address@hidden> wrote:

On Tue, 18 Apr 2017, D Bro wrote:

Both 26.0 and 25.1 on OS X 10.12 via homebrew, using the Spacemacs configuration.

I recently tried the weaving technique from http://orgmode.org/manual/noweb_002dref.html#noweb_002dref <http://orgmode.org/manual/noweb_002dref.html#noweb_002dref> :


Using M-x org-lint on your example gives

    3 high  Unknown header argument ":classname"
   12 high  Incorrect location for PROPERTIES drawer

The latter is because the drawer is not immediately after a headline and is disregarded:

**Let's see what our code-weaving produces
:header-args: :noweb-ref testdemo2

If you put a space between `**' and `L[...]' the line becomes a valid headline. Then the TestDemo2 src block produces

 | public class Yo {
 | public static void main (Args[]) {
 | return "The test worked!";
 | //
 | }}
 | cat TestDemo2.java

on ASCII export.

You can ignore the message about :classname, which comes from ob-java not defining it as a header-arg.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]