[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] :noweb-ref property inheritance failure?

From: Charles C. Berry
Subject: Re: [O] :noweb-ref property inheritance failure?
Date: Tue, 18 Apr 2017 19:04:35 -0700
User-agent: Alpine 2.20 (OSX 67 2015-01-07)

On Tue, 18 Apr 2017, D Bro wrote:

Both 26.0 and 25.1 on OS X 10.12 via homebrew, using the Spacemacs 

I recently tried the weaving technique from http://orgmode.org/manual/noweb_002dref.html#noweb_002dref <http://orgmode.org/manual/noweb_002dref.html#noweb_002dref> :


Using M-x org-lint on your example gives

     3 high  Unknown header argument ":classname"
    12 high  Incorrect location for PROPERTIES drawer

The latter is because the drawer is not immediately after a headline and is disregarded:

**Let's see what our code-weaving produces
:header-args: :noweb-ref testdemo2

If you put a space between `**' and `L[...]' the line becomes a valid headline. Then the TestDemo2 src block produces

  | public class Yo {
  | public static void main (Args[]) {
  | return "The test worked!";
  | //
  | }}
  | cat TestDemo2.java

on ASCII export.

You can ignore the message about :classname, which comes from ob-java not defining it as a header-arg.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]