[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] wrong type argument listp... org-element-set-contents

From: Kyle Meyer
Subject: Re: [O] wrong type argument listp... org-element-set-contents
Date: Sat, 08 Aug 2015 11:59:27 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Peter Salazar <address@hidden> wrote:
> Yes! That worked. What does this mean?
> I tried going to package-list-packages and uninstalling and reinstalling
> org, but that didn't help. What's my next step?
> On Sat, Aug 8, 2015 at 9:27 AM, Nicolas Goaziou <address@hidden>
> wrote:
>> Peter Salazar <address@hidden> writes:
>> > Sure, I'll try that. I'm not quite sure how to figure out what
>> > argument org-export-dispatch takes. Something like this? (org-reload
>> > (org-export-dispatch 'html))
>> I meant C-u M-x org-reload. Then regular export (e.g., C-c C-e l L).

Nicolas might have a better suggestion of what to do next, but I think
it means the state of your Emacs session was interfering with the
correct compilation.  Since 'C-u M-x org-reload' forced an uncompiled
reload, you could try uninstalling/installing the package again.  Or you
try Ista's snippet[1] for installing in a fresh session:

    Since it doesn't work for you I suggest removing org-plus-contrib
    (or org), starting emacs with 'emacs -Q' and running something like

    (require 'package)
    (add-to-list 'package-archives
                 '("org" . "http://orgmode.org/elpa/";) t)
    (package-install 'org-plus-contrib)
    ;; or (package-install 'org)

[1] http://permalink.gmane.org/gmane.emacs.orgmode/99708


reply via email to

[Prev in Thread] Current Thread [Next in Thread]