[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] makefile for v. 7.9.1 on Windows 7 doesn't work

From: Jonathan Leech-Pepin
Subject: Re: [O] makefile for v. 7.9.1 on Windows 7 doesn't work
Date: Fri, 7 Sep 2012 08:45:05 -0400


On Fri, Sep 7, 2012 at 8:33 AM, John Hendy <address@hidden> wrote:
> On Fri, Sep 7, 2012 at 2:13 AM, Bostjan Vilfan <address@hidden> wrote:
>> Hello,
>> I notice that the makefile in version 7.9.1 has been changed (with regard to 
>> v. 7.8.11). When I tried to run it under Windows7, it didn't work (the 
>> makefile for 7.8.11 ran OK). Can anyone provide some information?
> Can you provide more information? The error, what you were doing, etc?
> The last time I git pulled perhaps a week or so ago, I tried following
> Worg like so:[1]
> ,---
> | emacs -batch -Q -L lisp -l ../UTILITIES/org-fixup -f
> org-make-autoloads-compile
> `---
> It failed. I inspected the dit directory and noticed that it's  not
> ../UTILITIES anymore; all of the make stuff is in ../mk. Could that be
> the problem if you're following Worg?

If the problem is related to the missing =UTILITIES= directory, the
solution would seem to be just re-run the update.  I had that issue on
several machines, all of which complained the first time about the
missing =UTILITIES= directory and then ran successfullly on the
subsequent updates.

> As an aside, I just tried re-compiling to check and I noticed that if
> I follow Worg and cd into /path/to/org.git/mk and then run =emace
> -batch ... ../mk/org-fixup.el ...=, I get the error:
> ,---
> | Symbol's function definition is void: org-find-library-dir
> `---
> If I cd to /path/to/org.git and run the command with only one perios
> (=emacs ... ./mk/org-fixup.el ...=), then it works. But =M-x
> org-version= spits out something related to org-fixup and isn't a real
> version number.
> In any case, I can still compile as far as I know. Sorry if this
> wasn't your issue, but with the lack of details no one will be able to
> help you diagnose the problem.
> Best regards,
> John
> [1] http://orgmode.org/worg/org-hacks.html#compiling-org-without-make
>> Regards,
>> bostjanv



reply via email to

[Prev in Thread] Current Thread [Next in Thread]