[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Emacs-orgmode] New test version: org-4.19a

From: Scott Otterson
Subject: Re: [Emacs-orgmode] New test version: org-4.19a
Date: Thu, 30 Mar 2006 09:52:27 -0800
User-agent: Thunderbird 1.5 (X11/20051201)

Good idea about the *Messages* buffer -- I've always completely ignored it. Looking at it over, I realized that my problem is due to a conflict between org-4-19a and an old allout setting I had in my .emacs. With these lines in my .emacs:

(defvar rf-allout-font-lock-keywords
    ;; Highlight headings according to the level.
    (eval . (list (concat "^\\(" outline-regexp "\\).+")
                0 '(or (cdr (assq (outline-depth)
                                  '((1 . font-lock-function-name-face)
                                    (2 . font-lock-variable-name-face)
                                    (3 . font-lock-keyword-face)
                                    (4 . font-lock-builtin-face)
                                    (5 . font-lock-comment-face)
                                    (6 . font-lock-constant-face)
                                    (7 . font-lock-type-face)
                                    (8 . font-lock-string-face))))
                nil t)))
  "Additional expressions to highlight in Outline mode.")

;; add font-lock to allout mode
(defun rf-allout-font-lock-hook ()
  (set (make-local-variable 'font-lock-defaults)
       '(rf-allout-font-lock-keywords t nil nil
  ; doesn't work here? works if use emacs customizer (so leave it there)
  ;(setq outline-plain-bullets-string "-*-*-")  ; not fontlocking...
  ; lead w/ spaces, could instead use: `outline-use-mode-specific-leader'
  ;(setq outline-header-prefix ".")

(add-hook 'outline-mode-hook 'rf-allout-font-lock-hook)

I got this message in *Messages*:

  Error during redisplay: (void-function outline-depth) [7 times]

When I removed the allout settings above, the error went away and fontlocking in org-mode works again.

Links now display very nicely.  A couple comments

* URL links work great.  I think this is a big improvement!

* It would be nice if file TAB completion worked after the minibuffer "Link" prompt

* looks the stuff at the top of p. 18 of the manual has been obsoleted by this change. Tthe <>'s are no longer neded in "[[<http://www.gnu.org/software/emacs/>][GNU Emacs]])" although they still work.

* Are the <>'s required anymore? At the C-c C-l "Link:" prompt is it possible to write things so that you can just type:
instead of:

* It would be cool if file TAB completion worked after typing "file:"

* If I hit BACKSPACE in a link, then the guts of the link are displayed. But then it's not clear how to repair the link to make them hidden again.

Thanks for the changes,


Carsten Dominik (03/29/2006 11:49 PM) wrote:
I cannot reproduce this under Emacs I tried under Linux and under MacOS, works fine in both cases.

Is there something in the *Messages* buffer that looks suspicious? What if you turn off font-lock-mode, and then turn it back on?

How does your font-lock and org-mode related setup look like, have you configured something I don't?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]