[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strange char echo

From: Thomas Dickey
Subject: Re: strange char echo
Date: Tue, 10 Nov 2009 16:37:26 -0500 (EST)

On Tue, 10 Nov 2009, Bryan Christ wrote:

I added these lines to my application (after initscr) and the problem
went away...

term_desc.c_lflag &= ~(ECHO);

The version of ncurses I am using is:
ncurses = 5.7 (20081102)

Any known bugs of this nature with this build?

not that I recall - low-level I/O was not touched much for a while.

(this year, I've made a number of changes, and broken initialization 2-3

On Fri, 2009-11-06 at 21:36 +0000, Thomas Dickey wrote:
On Fri, 6 Nov 2009, Bryan Christ wrote:

Now that I think of it, I've only seen this problem when I try to run my
software on a remote systems via SSH.  I just tried to reproduce it
locally and couldn't.  The problem manifests 9 out of 10 times on remote
connections.  When I tried it 10 times locally, 100% pass.


just guessing - ssh may not be passing the ioctl information along
fast enough to make it look as if it succeeded.

I'd investigate it by building the application with ncurses' tracing
turned on (normally a feature of the debug-library...).

On Thu, 2009-11-05 at 23:56 +0000, Thomas Dickey wrote:
On Thu, 5 Nov 2009, Bryan Christ wrote:

does anyone know what might cause characters to be echoed to the screen
even though noecho() was called at startup?

aside from a new bug report?

It's possible that the ioctl to disable echoing is failing, e.g., if
stdout is redirected.

(n)curses disables echo at initialization, and simulates the echo/noecho

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]