[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-inetutils] [PATCH 6/7] argp'fied argument parsing & tiny fixes

From: Alfred M. Szmidt
Subject: Re: [bug-inetutils] [PATCH 6/7] argp'fied argument parsing & tiny fixes
Date: Sat, 23 Aug 2008 05:14:37 -0400

   +  /* FIXME: Argument name and argument description doesn't match */
   +  /* XXX: Changed required_argument to no_argument, since there
   +   * is not any use for it's argument value in current code. */
   +  {"log-sessions", 'L', NULL, 0, "Set local domain name", GRP+1},

Do we have a better name for this switch?  We could mark
--log-sessions as deprected, and use something more sensible.

   +#if defined(KERBEROS) || defined(SHISHI)
   +  {"kerberos", 'k', NULL, 0, "Use kerberos IV authentication", GRP+1},
   +  {"vacuous", 'v', NULL, OPT_HIDDEN, NULL, GRP+1},
   +# ifdef ENCRYPTION
   +  {"encryption", 'x', NULL, 0, "Use DES encryption", GRP+1},
   +# endif

Same here, warn the user that those specific switches are not
avaiable, but don't say that they do not exist when they do...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]