[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-inetutils] [PATCH 6/7] argp'fied argument parsing & tiny fixes

From: Arash Yadegarnia
Subject: Re: [bug-inetutils] [PATCH 6/7] argp'fied argument parsing & tiny fixes
Date: Sat, 30 Aug 2008 00:07:45 +0430

On Sat, 2008-08-23 at 05:14 -0400, Alfred M. Szmidt wrote: 
> +  /* FIXME: Argument name and argument description doesn't match */
>    +  /* XXX: Changed required_argument to no_argument, since there
>    +   * is not any use for it's argument value in current code. */
>    +  {"log-sessions", 'L', NULL, 0, "Set local domain name", GRP+1},
> Do we have a better name for this switch?  We could mark
> --log-sessions as deprected, and use something more sensible.
I think argument name is OK. This option is supposed to log session
activity. The one to blame here is the description. I've changed the
description to something more meaningful. 
>    +#if defined(KERBEROS) || defined(SHISHI)
>    +  {"kerberos", 'k', NULL, 0, "Use kerberos IV authentication", GRP+1},
>    +  {"vacuous", 'v', NULL, OPT_HIDDEN, NULL, GRP+1},
>    +# ifdef ENCRYPTION
>    +  {"encryption", 'x', NULL, 0, "Use DES encryption", GRP+1},
>    +# endif
>    +#endif
> Same here, warn the user that those specific switches are not
> avaiable, but don't say that they do not exist when they do...

        * rshd/rshd.c: Include <argp.h>.  Remove include for <getopt.h>.
        (ARGP_PROGRAM_DATA): Call macro.
        (argp, args_doc, doc, argp_options): New variables.
        (parse_opt): New function.
        (help, usage): Functions removed.
        (short_options, long_options): Variables removed.
        (main): Added new variable INDEX. Use argp to parse program

Updated patch is attached.

Attachment: rshd.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]