bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: push parser


From: Paul Eggert
Subject: Re: push parser
Date: Tue, 26 Sep 2006 10:28:15 -0700
User-agent: Gnus/5.1008 (Gnus v5.10.8) Emacs/21.4 (gnu/linux)

That looks good.  Some minor comments:

The usual style is to give local variables lower-case names.
The patch uses upper-caes names for local vars, which looks a bit strange.

> +]b4_locations_if([status = yypushparse (ctx, ch, &yylval, &yylloc);],
> +                 [status = yypushparse (ctx, ch, &yylval);])[

This won't be indented well, and has duplicate code.  The usual style is:

   status = yypushparse (ctx, ch, &yylval]b4_locations_if([, &yylloc])[);




reply via email to

[Prev in Thread] Current Thread [Next in Thread]