qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC/PATCH v0 03/12] gunyah: Basic support


From: Alex Bennée
Subject: Re: [RFC/PATCH v0 03/12] gunyah: Basic support
Date: Thu, 12 Oct 2023 12:32:34 +0100
User-agent: mu4e 1.11.22; emacs 29.1.50

Philippe Mathieu-Daudé <philmd@linaro.org> writes:

> Hi Srivatsa,
>
> On 11/10/23 18:52, Srivatsa Vaddagiri wrote:
>> Add a new accelerator, gunyah, with basic functionality of creating a
>> VM. Subsequent patches will add support for other functions required to
>> run a VM.
>> Signed-off-by: Srivatsa Vaddagiri <quic_svaddagi@quicinc.com>
>> ---
>>   MAINTAINERS                     |   7 +++
>>   accel/Kconfig                   |   3 +
>>   accel/gunyah/gunyah-accel-ops.c | 102 ++++++++++++++++++++++++++++++++
>>   accel/gunyah/gunyah-all.c       |  70 ++++++++++++++++++++++
>>   accel/gunyah/meson.build        |   7 +++
>>   accel/meson.build               |   1 +
>>   accel/stubs/gunyah-stub.c       |  13 ++++
>>   accel/stubs/meson.build         |   1 +
>>   docs/about/build-platforms.rst  |   2 +-
>>   hw/arm/virt.c                   |   3 +
>>   include/sysemu/gunyah.h         |  43 ++++++++++++++
>>   include/sysemu/gunyah_int.h     |  27 +++++++++
>>   meson.build                     |   9 +++
>>   meson_options.txt               |   2 +
>>   scripts/meson-buildoptions.sh   |   3 +
>>   target/arm/cpu64.c              |   5 +-
>>   16 files changed, 295 insertions(+), 3 deletions(-)
>>   create mode 100644 accel/gunyah/gunyah-accel-ops.c
>>   create mode 100644 accel/gunyah/gunyah-all.c
>>   create mode 100644 accel/gunyah/meson.build
>>   create mode 100644 accel/stubs/gunyah-stub.c
>>   create mode 100644 include/sysemu/gunyah.h
>>   create mode 100644 include/sysemu/gunyah_int.h
>
> Can we move gunyah_int.h to accel/gunyah/?

If it's all internal to gunyah itself you could rename it to internal.h
(although we do have various forms of foo-internal.h across the code
base).

However I see the reason is the other accelerators have done so:

       accel/hvf/hvf-accel-ops.c
  58:#include "sysemu/hvf_int.h"
       accel/hvf/hvf-all.c
  14:#include "sysemu/hvf_int.h"
       accel/kvm/kvm-accel-ops.c
  20:#include "sysemu/kvm_int.h"
       accel/kvm/kvm-all.c
  31:#include "sysemu/kvm_int.h"

-- 
Alex Bennée
Virtualisation Tech Lead @ Linaro



reply via email to

[Prev in Thread] Current Thread [Next in Thread]