help-octave
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: handling NaN


From: John W. Eaton
Subject: Re: handling NaN
Date: Thu, 8 Aug 2002 14:22:35 -0500

On  8-Aug-2002, Paul Kienzle <address@hidden> wrote:

| <rant>
| I hate having to remember if it is "is_condition" or "iscondition".  Could
| we please use "iscondition" for all new tests?  In this case, isNA, or
| better yet, isna.
| </rant>

I thought you might say that.  :-)

OK, it doesn't matter much to me, and I think Matlab mostly avoids
underscores in names, so there are some stupid incompatiblity problems
like is_global vs. isglobal.

Currently we seem to have

  is_abcd             is_siso             isgraph
  is_bool             is_square           ishold
  is_complex          is_stabilizable     isieee
  is_controllable     is_stable           isinf
  is_detectable       is_stream           isletter
  is_dgkf             is_struct           islogical
  is_digital          is_symmetric        islower
  is_duplicate_entry  is_vector           isnan
  is_global           isalnum             isnumeric
  is_leap_year        isalpha             isprint
  is_list             isascii             ispunct
  is_matrix           iscell              isreal
  is_observable       iscntrl             isspace
  is_sample           isdigit             isstr
  is_scalar           isempty             isupper
  is_signal_list      isfinite            isxdigit

so I suppose we can remove the underscores from all of them, except
maybe we should keep the underscores in is_signal_list,
is_duplicate_entry, and is_leap_year, since they are already two
words.  I think I would find it hard to read isleapyear.

Not that we are trying to be compatible with Emacs Lisp too, but this
convention would then be consistent with the one used there, in which
predicates are named things like stringp if the root of the predicate
starts out as a single word, and user-variable-p if the root is two or
more words.

For each function that we rename, we could introduce a
scripts/deprecated directory and put M-files there that have the old
name for compatibility.

Is that an acceptable solution?

jwe



-------------------------------------------------------------
Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:  http://www.octave.org
How to fund new projects:  http://www.octave.org/funding.html
Subscription information:  http://www.octave.org/archive.html
-------------------------------------------------------------



reply via email to

[Prev in Thread] Current Thread [Next in Thread]