[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 5/6] Replace "iothread lock" with "BQL" in comments
From: |
Philippe Mathieu-Daudé |
Subject: |
Re: [PATCH 5/6] Replace "iothread lock" with "BQL" in comments |
Date: |
Thu, 30 Nov 2023 14:47:49 +0100 |
User-agent: |
Mozilla Thunderbird |
Hi Stefan,
On 29/11/23 22:26, Stefan Hajnoczi wrote:
The term "iothread lock" is obsolete. The APIs use Big QEMU Lock (BQL)
in their names. Update the code comments to use "BQL" instead of
"iothread lock".
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
docs/devel/reset.rst | 2 +-
hw/display/qxl.h | 2 +-
include/exec/cpu-common.h | 2 +-
include/exec/memory.h | 4 ++--
include/exec/ramblock.h | 2 +-
include/migration/register.h | 8 ++++----
target/arm/internals.h | 4 ++--
accel/tcg/cputlb.c | 4 ++--
accel/tcg/tcg-accel-ops-icount.c | 2 +-
hw/remote/mpqemu-link.c | 2 +-
migration/block-dirty-bitmap.c | 10 +++++-----
migration/block.c | 24 ++++++++++++------------
migration/colo.c | 2 +-
migration/migration.c | 2 +-
migration/ram.c | 4 ++--
system/physmem.c | 6 +++---
target/arm/helper.c | 2 +-
target/arm/tcg/m_helper.c | 2 +-
ui/spice-core.c | 2 +-
util/rcu.c | 2 +-
audio/coreaudio.m | 4 ++--
ui/cocoa.m | 6 +++---
22 files changed, 49 insertions(+), 49 deletions(-)
diff --git a/include/exec/ramblock.h b/include/exec/ramblock.h
index 69c6a53902..a2bc0a345d 100644
--- a/include/exec/ramblock.h
+++ b/include/exec/ramblock.h
@@ -34,7 +34,7 @@ struct RAMBlock {
ram_addr_t max_length;
void (*resized)(const char*, uint64_t length, void *host);
uint32_t flags;
- /* Protected by iothread lock. */
+ /* Protected by BQL. */
There is only one single BQL, so preferably:
"by the BQL"
char idstr[256];
/* RCU-enabled, writes protected by the ramlist lock */
QLIST_ENTRY(RAMBlock) next;
-/* Called with iothread lock taken. */
+/* Called with BQL taken. */
"with the BQL" (other uses)
Otherwise,
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
static void dirty_bitmap_do_save_cleanup(DBMSaveState *s)
{
SaveBitmapState *dbms;
@@ -479,7 +479,7 @@ static void dirty_bitmap_do_save_cleanup(DBMSaveState *s)
}
}
- Re: [PATCH 3/6] qemu/main-loop: rename qemu_cond_wait_iothread() to qemu_cond_wait_bql(), (continued)
- [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Stefan Hajnoczi, 2023/11/29
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Paul Durrant, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Fabiano Rosas, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), David Woodhouse, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Cédric Le Goater, 2023/11/30
- Re: [PATCH 1/6] system/cpus: rename qemu_mutex_lock_iothread() to qemu_bql_lock(), Peter Xu, 2023/11/30
- [PATCH 5/6] Replace "iothread lock" with "BQL" in comments, Stefan Hajnoczi, 2023/11/29
- Re: [PATCH 5/6] Replace "iothread lock" with "BQL" in comments,
Philippe Mathieu-Daudé <=
- [PATCH 6/6] Rename "QEMU global mutex" to "BQL" in comments and docs, Stefan Hajnoczi, 2023/11/29