[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[RFC PATCH v2 6/9] accel/tcg: Check for USER_ONLY definition instead of
From: |
Philippe Mathieu-Daudé |
Subject: |
[RFC PATCH v2 6/9] accel/tcg: Check for USER_ONLY definition instead of SOFTMMU one |
Date: |
Tue, 6 Jun 2023 00:24:17 +0200 |
Since we *might* have user emulation with softmmu,
replace the system emulation check by !user emulation one.
Invert some if() ladders for clarity.
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
accel/tcg/internal.h | 6 +++---
accel/tcg/cpu-exec.c | 4 ++--
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/accel/tcg/internal.h b/accel/tcg/internal.h
index 24f225cac7..65380ccb42 100644
--- a/accel/tcg/internal.h
+++ b/accel/tcg/internal.h
@@ -17,10 +17,10 @@
* memory related structures are protected with mmap_lock.
* In !user-mode we use per-page locks.
*/
-#ifdef CONFIG_SOFTMMU
-#define assert_memory_lock()
-#else
+#ifdef CONFIG_USER_ONLY
#define assert_memory_lock() tcg_debug_assert(have_mmap_lock())
+#else
+#define assert_memory_lock()
#endif
#if defined(CONFIG_SOFTMMU) && defined(CONFIG_DEBUG_TCG)
diff --git a/accel/tcg/cpu-exec.c b/accel/tcg/cpu-exec.c
index 1cf4f1fa22..cf07e6740f 100644
--- a/accel/tcg/cpu-exec.c
+++ b/accel/tcg/cpu-exec.c
@@ -563,7 +563,7 @@ void cpu_exec_step_atomic(CPUState *cpu)
cpu_tb_exec(cpu, tb, &tb_exit);
cpu_exec_exit(cpu);
} else {
-#ifndef CONFIG_SOFTMMU
+#ifdef CONFIG_USER_ONLY
clear_helper_retaddr();
if (have_mmap_lock()) {
mmap_unlock();
@@ -1020,7 +1020,7 @@ static int cpu_exec_setjmp(CPUState *cpu, SyncClocks *sc)
/* Non-buggy compilers preserve this; assert the correct value. */
g_assert(cpu == current_cpu);
-#ifndef CONFIG_SOFTMMU
+#ifdef CONFIG_USER_ONLY
clear_helper_retaddr();
if (have_mmap_lock()) {
mmap_unlock();
--
2.38.1
- [RFC PATCH v2 1/9] target/tricore: Remove pointless CONFIG_SOFTMMU guard, (continued)
- [RFC PATCH v2 1/9] target/tricore: Remove pointless CONFIG_SOFTMMU guard, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 2/9] target/i386: Check for USER_ONLY definition instead of SOFTMMU one, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 3/9] target/m68k: Check for USER_ONLY definition instead of SOFTMMU one, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 4/9] target/ppc: Check for USER_ONLY definition instead of SOFTMMU one, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 5/9] hw/core/cpu: Check for USER_ONLY definition instead of SOFTMMU one, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 6/9] accel/tcg: Check for USER_ONLY definition instead of SOFTMMU one,
Philippe Mathieu-Daudé <=
- [RFC PATCH v2 7/9] meson: Alias CONFIG_SOFTMMU -> CONFIG_SYSTEM_ONLY, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 8/9] meson: Replace CONFIG_SOFTMMU -> CONFIG_SYSTEM_ONLY, Philippe Mathieu-Daudé, 2023/06/05
- [RFC PATCH v2 9/9] meson: Replace softmmu_ss -> system_ss, Philippe Mathieu-Daudé, 2023/06/05
- Re: [RFC PATCH v2 0/9] bulk: Replace CONFIG_SOFTMMU by !CONFIG_USER_ONLY/CONFIG_SYSTEM_ONLY, Philippe Mathieu-Daudé, 2023/06/05