[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 02/10] dump: Rename write_elf_loads to write_elf_phdr_loads
From: |
marcandre . lureau |
Subject: |
[PULL 02/10] dump: Rename write_elf_loads to write_elf_phdr_loads |
Date: |
Thu, 6 Oct 2022 19:34:21 +0400 |
From: Janosch Frank <frankja@linux.ibm.com>
Let's make it a bit clearer that we write the program headers of the
PT_LOAD type.
Signed-off-by: Janosch Frank <frankja@linux.ibm.com>
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Reviewed-by: Janis Schoetterl-Glausch <scgl@linux.ibm.com>
Reviewed-by: Steffen Eiden <seiden@ibm.linux.com>
Message-Id: <20220811121111.9878-3-frankja@linux.ibm.com>
---
dump/dump.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/dump/dump.c b/dump/dump.c
index 4d9658ffa2..0ed7cf9c7b 100644
--- a/dump/dump.c
+++ b/dump/dump.c
@@ -490,7 +490,7 @@ static void get_offset_range(hwaddr phys_addr,
}
}
-static void write_elf_loads(DumpState *s, Error **errp)
+static void write_elf_phdr_loads(DumpState *s, Error **errp)
{
ERRP_GUARD();
hwaddr offset, filesz;
@@ -573,8 +573,8 @@ static void dump_begin(DumpState *s, Error **errp)
return;
}
- /* write all PT_LOAD to vmcore */
- write_elf_loads(s, errp);
+ /* write all PT_LOADs to vmcore */
+ write_elf_phdr_loads(s, errp);
if (*errp) {
return;
}
--
2.37.3
- [PULL 00/10] Dump patches, marcandre . lureau, 2022/10/06
- [PULL 01/10] dump: Replace opaque DumpState pointer with a typed one, marcandre . lureau, 2022/10/06
- [PULL 02/10] dump: Rename write_elf_loads to write_elf_phdr_loads,
marcandre . lureau <=
- [PULL 03/10] dump: Refactor dump_iterate and introduce dump_filter_memblock_*(), marcandre . lureau, 2022/10/06
- [PULL 04/10] dump: Rework get_start_block, marcandre . lureau, 2022/10/06
- [PULL 05/10] dump: Rework filter area variables, marcandre . lureau, 2022/10/06
- [PULL 06/10] dump: Rework dump_calculate_size function, marcandre . lureau, 2022/10/06
- [PULL 09/10] dump: simplify a bit kdump get_next_page(), marcandre . lureau, 2022/10/06
- [PULL 07/10] dump: Split elf header functions into prepare and write, marcandre . lureau, 2022/10/06
- [PULL 08/10] dump: Rename write_elf*_phdr_note to prepare_elf*_phdr_note, marcandre . lureau, 2022/10/06
- [PULL 10/10] dump: fix kdump to work over non-aligned blocks, marcandre . lureau, 2022/10/06
- Re: [PULL 00/10] Dump patches, Stefan Hajnoczi, 2022/10/11