[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v4 04/17] dump: Rework get_start_block
From: |
Janosch Frank |
Subject: |
[PATCH v4 04/17] dump: Rework get_start_block |
Date: |
Tue, 26 Jul 2022 09:22:35 +0000 |
get_start_block() returns the start address of the first memory block
or -1.
With the GuestPhysBlock iterator conversion we don't need to set the
start address and can therefore remove that code. The only
functionality left is the validation of the start block so it only
makes sense to re-name the function to validate_start_block()
Signed-off-by: Janosch Frank <frankja@linux.ibm.com>
---
dump/dump.c | 20 ++++++--------------
1 file changed, 6 insertions(+), 14 deletions(-)
diff --git a/dump/dump.c b/dump/dump.c
index 35b9833a00..b59faf9941 100644
--- a/dump/dump.c
+++ b/dump/dump.c
@@ -1498,30 +1498,22 @@ static void create_kdump_vmcore(DumpState *s, Error
**errp)
}
}
-static ram_addr_t get_start_block(DumpState *s)
+static int validate_start_block(DumpState *s)
{
GuestPhysBlock *block;
if (!s->has_filter) {
- s->next_block = QTAILQ_FIRST(&s->guest_phys_blocks.head);
return 0;
}
QTAILQ_FOREACH(block, &s->guest_phys_blocks.head, next) {
+ /* This block is out of the range */
if (block->target_start >= s->begin + s->length ||
block->target_end <= s->begin) {
- /* This block is out of the range */
continue;
}
-
- s->next_block = block;
- if (s->begin > block->target_start) {
- s->start = s->begin - block->target_start;
- } else {
- s->start = 0;
- }
- return s->start;
- }
+ return 0;
+ }
return -1;
}
@@ -1668,8 +1660,8 @@ static void dump_init(DumpState *s, int fd, bool
has_format,
goto cleanup;
}
- s->start = get_start_block(s);
- if (s->start == -1) {
+ /* Is the filter filtering everything? */
+ if (validate_start_block(s) == -1) {
error_setg(errp, QERR_INVALID_PARAMETER, "begin");
goto cleanup;
}
--
2.34.1
- Re: [PATCH v4 03/17] dump: Convert GuestPhysBlock iterators and use the filter functions, (continued)
- [PATCH v4 01/17] dump: Rename write_elf_loads to write_elf_phdr_loads, Janosch Frank, 2022/07/26
- [PATCH v4 06/17] dump: Rework dump_calculate_size function, Janosch Frank, 2022/07/26
- [PATCH v4 05/17] dump: Cleanup and annotate guest memory related DumpState struct members, Janosch Frank, 2022/07/26
- [PATCH v4 07/17] dump: Allocate header, Janosch Frank, 2022/07/26
- [PATCH v4 04/17] dump: Rework get_start_block,
Janosch Frank <=
- [PATCH v4 08/17] dump: Split write of section headers and data and add a prepare step, Janosch Frank, 2022/07/26
- [PATCH v4 09/17] dump: Reorder struct DumpState, Janosch Frank, 2022/07/26
- [PATCH v4 10/17] dump: Swap segment and section header locations, Janosch Frank, 2022/07/26