[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 02/12] pc-bios/s390-ccw/virtio: Introduce a macro for the DAS
From: |
Eric Farman |
Subject: |
Re: [PATCH 02/12] pc-bios/s390-ccw/virtio: Introduce a macro for the DASD block size |
Date: |
Fri, 01 Jul 2022 10:53:58 -0400 |
On Tue, 2022-06-28 at 15:21 +0200, Cornelia Huck wrote:
> On Tue, Jun 28 2022, Thomas Huth <thuth@redhat.com> wrote:
>
> > Use VIRTIO_DASD_BLOCK_SIZE instead of the magic value 4096.
> >
> > Signed-off-by: Thomas Huth <thuth@redhat.com>
> > ---
> > pc-bios/s390-ccw/virtio.h | 1 +
> > pc-bios/s390-ccw/virtio-blkdev.c | 2 +-
> > 2 files changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/pc-bios/s390-ccw/virtio.h b/pc-bios/s390-ccw/virtio.h
> > index 19fceb6495..c2c17c29ca 100644
> > --- a/pc-bios/s390-ccw/virtio.h
> > +++ b/pc-bios/s390-ccw/virtio.h
> > @@ -198,6 +198,7 @@ extern int virtio_read_many(ulong sector, void
> > *load_addr, int sec_num);
> > #define VIRTIO_SECTOR_SIZE 512
> > #define VIRTIO_ISO_BLOCK_SIZE 2048
> > #define VIRTIO_SCSI_BLOCK_SIZE 512
> > +#define VIRTIO_DASD_BLOCK_SIZE 4096
> >
> > static inline ulong virtio_sector_adjust(ulong sector)
> > {
> > diff --git a/pc-bios/s390-ccw/virtio-blkdev.c b/pc-bios/s390-
> > ccw/virtio-blkdev.c
> > index 7d35050292..49ed2b4bee 100644
> > --- a/pc-bios/s390-ccw/virtio-blkdev.c
> > +++ b/pc-bios/s390-ccw/virtio-blkdev.c
> > @@ -155,7 +155,7 @@ void virtio_assume_eckd(void)
> > vdev->config.blk.physical_block_exp = 0;
> > switch (vdev->senseid.cu_model) {
> > case VIRTIO_ID_BLOCK:
> > - vdev->config.blk.blk_size = 4096;
> > + vdev->config.blk.blk_size = VIRTIO_DASD_BLOCK_SIZE;
> > break;
> > case VIRTIO_ID_SCSI:
> > vdev->config.blk.blk_size = vdev->scsi_block_size;
>
> Unrelated to this change, but can't dasd be formatted with other
> block
> sizes as well?
True. I'd guess it's unlikely that anyone is jumping through those
hoops, though.
This is fine.
Reviewed-by: Eric Farman <farman@linux.ibm.com>
>
- Re: [PATCH 02/12] pc-bios/s390-ccw/virtio: Introduce a macro for the DASD block size,
Eric Farman <=