[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2
From: |
Cornelia Huck |
Subject: |
Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2 |
Date: |
Mon, 11 Jan 2021 14:43:22 +0100 |
On Mon, 11 Jan 2021 08:00:45 -0500
"Michael S. Tsirkin" <mst@redhat.com> wrote:
> On Mon, Jan 11, 2021 at 01:54:04PM +0100, Cornelia Huck wrote:
> > On Mon, 4 Jan 2021 21:20:56 +0100
> > Eric Farman <farman@linux.ibm.com> wrote:
> >
> > > Signed-off-by: Eric Farman <farman@linux.ibm.com>
> > > ---
> > > .../infiniband/hw/vmw_pvrdma/pvrdma_ring.h | 14 +-
> > > .../infiniband/hw/vmw_pvrdma/pvrdma_verbs.h | 2 +-
> > > include/standard-headers/drm/drm_fourcc.h | 175 +++++++++++++++++-
> > > include/standard-headers/linux/const.h | 36 ++++
> > > include/standard-headers/linux/ethtool.h | 2 +-
> > > include/standard-headers/linux/fuse.h | 30 ++-
> > > include/standard-headers/linux/kernel.h | 9 +-
> > > include/standard-headers/linux/pci_regs.h | 16 ++
> > > include/standard-headers/linux/vhost_types.h | 9 +
> > > include/standard-headers/linux/virtio_gpu.h | 82 ++++++++
> > > include/standard-headers/linux/virtio_ids.h | 44 +++--
> > > linux-headers/asm-arm64/kvm.h | 3 -
> > > linux-headers/asm-generic/unistd.h | 6 +-
> > > linux-headers/asm-mips/unistd_n32.h | 1 +
> > > linux-headers/asm-mips/unistd_n64.h | 1 +
> > > linux-headers/asm-mips/unistd_o32.h | 1 +
> > > linux-headers/asm-powerpc/unistd_32.h | 1 +
> > > linux-headers/asm-powerpc/unistd_64.h | 1 +
> > > linux-headers/asm-s390/unistd_32.h | 1 +
> > > linux-headers/asm-s390/unistd_64.h | 1 +
> > > linux-headers/asm-x86/kvm.h | 1 +
> > > linux-headers/asm-x86/unistd_32.h | 1 +
> > > linux-headers/asm-x86/unistd_64.h | 1 +
> > > linux-headers/asm-x86/unistd_x32.h | 1 +
> > > linux-headers/linux/kvm.h | 56 +++++-
> > > linux-headers/linux/userfaultfd.h | 9 +
> > > linux-headers/linux/vfio.h | 1 +
> > > linux-headers/linux/vhost.h | 4 +
> > > 28 files changed, 461 insertions(+), 48 deletions(-)
> > > create mode 100644 include/standard-headers/linux/const.h
> > >
> > > diff --git
> > > a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > > b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > > index 7b4062a1a1..acd4c8346d 100644
> > > ---
> > > a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > > +++
> > > b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> > > @@ -68,7 +68,7 @@ static inline int pvrdma_idx_valid(uint32_t idx,
> > > uint32_t max_elems)
> > >
> > > static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
> > > {
> > > - const unsigned int idx = qatomic_read(var);
> > > + const unsigned int idx = atomic_read(var);
> >
> > Hm, what was the state of these qatomic* instances in this header? Is
> > it ok to rename them, or do we need to do some munging in the import
> > script?
> >
> > (Sorry, it's been a while.)
>
>
> Yea looks like it was done manually last time:
>
> commit d73415a315471ac0b127ed3fad45c8ec5d711de1
> Author: Stefan Hajnoczi <stefanha@redhat.com>
> Date: Wed Sep 23 11:56:46 2020 +0100
>
> qemu/atomic.h: rename atomic_ to qatomic_
It seems that this hunk was dropped manually last time:
commit 53ba2eee52bff5a746e96835539a1079f6bcadd1
Author: Matthew Rosato <mjrosato@linux.ibm.com>
Date: Mon Oct 26 11:34:30 2020 -0400
linux-headers: update against 5.10-rc1
commit 3650b228f83adda7e5ee532e2b90429c03f7b9ec
Signed-off-by: Matthew Rosato <mjrosato@linux.ibm.com>
[aw: drop pvrdma_ring.h changes to avoid revert of d73415a31547
("qemu/atomic.h: rename atomic_ to qatomic_")]
Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
I can do that as well, but I'm not sure that this is the best way
forward.
>
>
>
> > >
> > > if (pvrdma_idx_valid(idx, max_elems))
> > > return idx & (max_elems - 1);
> > > @@ -77,17 +77,17 @@ static inline int32_t pvrdma_idx(int *var, uint32_t
> > > max_elems)
> > >
> > > static inline void pvrdma_idx_ring_inc(int *var, uint32_t max_elems)
> > > {
> > > - uint32_t idx = qatomic_read(var) + 1; /* Increment. */
> > > + uint32_t idx = atomic_read(var) + 1; /* Increment. */
> > >
> > > idx &= (max_elems << 1) - 1; /* Modulo size, flip gen. */
> > > - qatomic_set(var, idx);
> > > + atomic_set(var, idx);
> > > }
> > >
> > > static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring
> > > *r,
> > > uint32_t max_elems, uint32_t
> > > *out_tail)
> > > {
> > > - const uint32_t tail = qatomic_read(&r->prod_tail);
> > > - const uint32_t head = qatomic_read(&r->cons_head);
> > > + const uint32_t tail = atomic_read(&r->prod_tail);
> > > + const uint32_t head = atomic_read(&r->cons_head);
> > >
> > > if (pvrdma_idx_valid(tail, max_elems) &&
> > > pvrdma_idx_valid(head, max_elems)) {
> > > @@ -100,8 +100,8 @@ static inline int32_t pvrdma_idx_ring_has_space(const
> > > struct pvrdma_ring *r,
> > > static inline int32_t pvrdma_idx_ring_has_data(const struct pvrdma_ring
> > > *r,
> > > uint32_t max_elems, uint32_t
> > > *out_head)
> > > {
> > > - const uint32_t tail = qatomic_read(&r->prod_tail);
> > > - const uint32_t head = qatomic_read(&r->cons_head);
> > > + const uint32_t tail = atomic_read(&r->prod_tail);
> > > + const uint32_t head = atomic_read(&r->cons_head);
> > >
> > > if (pvrdma_idx_valid(tail, max_elems) &&
> > > pvrdma_idx_valid(head, max_elems)) {
>
- [PATCH v3 0/3] vfio-ccw: Implement request notifier, Eric Farman, 2021/01/04
- [PATCH v3 3/3] vfio-ccw: Connect the device request notifier, Eric Farman, 2021/01/04
- [PATCH v3 2/3] Update linux headers to 5.11-rc2, Eric Farman, 2021/01/04
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Cornelia Huck, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Michael S. Tsirkin, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2,
Cornelia Huck <=
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Michael S. Tsirkin, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Eric Farman, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Michael S. Tsirkin, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Cornelia Huck, 2021/01/11
- Re: [PATCH v3 2/3] Update linux headers to 5.11-rc2, Cornelia Huck, 2021/01/13
[PATCH v3 1/3] update-linux-headers: Include const.h, Eric Farman, 2021/01/04