[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 00/13] Vga 20200701 patches
From: |
Gerd Hoffmann |
Subject: |
[PULL 00/13] Vga 20200701 patches |
Date: |
Wed, 1 Jul 2020 17:04:12 +0200 |
The following changes since commit fc1bff958998910ec8d25db86cd2f53ff125f7ab:
hw/misc/pca9552: Add missing TypeInfo::class_size field (2020-06-29 21:16:10
+0100)
are available in the Git repository at:
git://git.kraxel.org/qemu tags/vga-20200701-pull-request
for you to fetch changes up to 8db2a4fd8abf6550479f7a8caa8f655c34238d6a:
configure: vgabios cleanups (2020-06-30 22:54:47 +0200)
----------------------------------------------------------------
vga: bugfixes for ati and sm501, vgabios cleanup.
----------------------------------------------------------------
BALATON Zoltan (12):
sm501: Fix bounds checks
sm501: Drop unneded variable
sm501: Ignore no-op blits
sm501: Introduce variable for commonly used value for better
readability
sm501: Optimise 1 pixel 2d ops
sm501: Use stn_he_p/ldn_he_p instead of switch/case
sm501: Do not allow guest to set invalid format
sm501: Convert debug printfs to traces
sm501: Fix and optimize overlap check
ati-vga: Support unaligned access to hardware cursor registers
ati-vga: Do not assert on error
ati-vga: Add dummy MEM_SDRAM_MODE_REG
Gerd Hoffmann (1):
configure: vgabios cleanups
configure | 6 +-
hw/display/ati_regs.h | 1 +
hw/display/ati.c | 92 +++++++++++++++--------
hw/display/ati_dbg.c | 1 +
hw/display/sm501.c | 157 +++++++++++++++++++---------------------
hw/display/trace-events | 12 +++
6 files changed, 155 insertions(+), 114 deletions(-)
--
2.18.4
- [PULL 00/13] Vga 20200701 patches,
Gerd Hoffmann <=
- [PULL 01/13] sm501: Fix bounds checks, Gerd Hoffmann, 2020/07/01
- [PULL 13/13] configure: vgabios cleanups, Gerd Hoffmann, 2020/07/01
- [PULL 03/13] sm501: Ignore no-op blits, Gerd Hoffmann, 2020/07/01
- [PULL 06/13] sm501: Use stn_he_p/ldn_he_p instead of switch/case, Gerd Hoffmann, 2020/07/01
- [PULL 09/13] sm501: Fix and optimize overlap check, Gerd Hoffmann, 2020/07/01
- [PULL 10/13] ati-vga: Support unaligned access to hardware cursor registers, Gerd Hoffmann, 2020/07/01
- [PULL 04/13] sm501: Introduce variable for commonly used value for better readability, Gerd Hoffmann, 2020/07/01
- [PULL 08/13] sm501: Convert debug printfs to traces, Gerd Hoffmann, 2020/07/01
- [PULL 02/13] sm501: Drop unneded variable, Gerd Hoffmann, 2020/07/01
- [PULL 12/13] ati-vga: Add dummy MEM_SDRAM_MODE_REG, Gerd Hoffmann, 2020/07/01