qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-ppc] [PATCH 0/4] Rename all 'dprintf' macros to 'DPRINTF'


From: Peter Maydell
Subject: [Qemu-ppc] [PATCH 0/4] Rename all 'dprintf' macros to 'DPRINTF'
Date: Mon, 29 Jul 2013 13:16:35 +0100

'dprintf' is the name of a POSIX standard function:
 http://pubs.opengroup.org/onlinepubs/9699919799/functions/dprintf.html
and so we should not steal the name to use as a debug macro.
The clang compiler in particular will emit a warning about this
redefinition:

  hw/net/spapr_llan.c:43:9: error: 'dprintf' macro redefined [-Werror]
#define dprintf(fmt...)
        ^
/usr/include/x86_64-linux-gnu/bits/stdio2.h:189:12: note: previous definition 
is here
#   define dprintf(fd, ...) \
           ^
1 error generated.

This patch series fixes this with the simple approach
of renaming all the users of a 'dprintf' macro to 'DPRINTF'
(which is what this macro is already called in a number of
other files in the tree). It's almost entirely a simple
search and replace; there are two cases where I folded an
overlong line that checkpatch complained about.


Peter Maydell (4):
  block/sheepdog: Rename 'dprintf' to 'DPRINTF'
  s390x: Rename 'dprintf' to 'DPRINTF'
  target-ppc/kvm.c: Rename 'dprintf' to 'DPRINTF'
  spapr: Rename 'dprintf' to 'DPRINTF'

 block/sheepdog.c           |   30 ++++++++++++-------------
 hw/net/spapr_llan.c        |   26 +++++++++++-----------
 hw/ppc/spapr_vio.c         |    8 +++----
 hw/s390x/s390-virtio-bus.c |    4 ++--
 hw/s390x/s390-virtio.c     |    4 ++--
 hw/scsi/spapr_vscsi.c      |   49 +++++++++++++++++++++--------------------
 target-ppc/kvm.c           |   52 ++++++++++++++++++++++----------------------
 target-s390x/kvm.c         |   19 ++++++++--------
 8 files changed, 97 insertions(+), 95 deletions(-)

-- 
1.7.9.5




reply via email to

[Prev in Thread] Current Thread [Next in Thread]