[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v10 03/21] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED
From: |
Igor Mammedov |
Subject: |
Re: [PATCH v10 03/21] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED |
Date: |
Tue, 17 Sep 2024 11:22:39 +0200 |
On Sat, 14 Sep 2024 08:13:24 +0200
Mauro Carvalho Chehab <mchehab+huawei@kernel.org> wrote:
> This is just duplicating ACPI_GHES_ERROR_SOURCE_COUNT, which
> has a better name. So, drop the duplication.
>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
> ---
> hw/acpi/ghes.c | 7 ++-----
> include/hw/acpi/ghes.h | 3 ++-
> 2 files changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
> index 529c14e3289f..35f793401d06 100644
> --- a/hw/acpi/ghes.c
> +++ b/hw/acpi/ghes.c
> @@ -35,9 +35,6 @@
> /* The max size in bytes for one error block */
> #define ACPI_GHES_MAX_RAW_DATA_LENGTH (1 * KiB)
>
> -/* Now only support ARMv8 SEA notification type error source */
> -#define ACPI_GHES_ERROR_SOURCE_COUNT 1
> -
> /* Generic Hardware Error Source version 2 */
> #define ACPI_GHES_SOURCE_GENERIC_ERROR_V2 10
>
> @@ -411,7 +408,7 @@ int acpi_ghes_record_errors(uint8_t source_id, uint64_t
> physical_address)
> AcpiGedState *acpi_ged_state;
> AcpiGhesState *ags;
>
> - assert(source_id < ACPI_HEST_SRC_ID_RESERVED);
> + assert(source_id < ACPI_GHES_ERROR_SOURCE_COUNT);
>
> acpi_ged_state = ACPI_GED(object_resolve_path_type("", TYPE_ACPI_GED,
> NULL));
> @@ -422,7 +419,7 @@ int acpi_ghes_record_errors(uint8_t source_id, uint64_t
> physical_address)
>
> if (physical_address) {
>
> - if (source_id < ACPI_HEST_SRC_ID_RESERVED) {
> + if (source_id < ACPI_GHES_ERROR_SOURCE_COUNT) {
> start_addr += source_id * sizeof(uint64_t);
> }
>
> diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
> index 28b956acb19a..5421ffcbb7fa 100644
> --- a/include/hw/acpi/ghes.h
> +++ b/include/hw/acpi/ghes.h
> @@ -59,7 +59,8 @@ enum AcpiGhesNotifyType {
> enum {
> ACPI_HEST_SRC_ID_SEA = 0,
> /* future ids go here */
> - ACPI_HEST_SRC_ID_RESERVED,
> +
> + ACPI_GHES_ERROR_SOURCE_COUNT
> };
>
> typedef struct AcpiGhesState {
- [PATCH v10 00/21] Add ACPI CPER firmware first error injection on ARM emulation, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 01/21] acpi/ghes: add a firmware file with HEST address, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 02/21] acpi/generic_event_device: Update GHES migration to cover hest addr, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 03/21] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/09/14
- Re: [PATCH v10 03/21] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED,
Igor Mammedov <=
- [PATCH v10 07/21] acpi/ghes: rework the logic to handle HEST source ID, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 14/21] acpi/ghes: add a notifier to notify when error data is ready, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 20/21] target/arm: add an experimental mpidr arm cpu property object, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 04/21] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 08/21] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 15/21] acpi/generic_event_device: add an APEI error device, Mauro Carvalho Chehab, 2024/09/14
- [PATCH v10 06/21] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/09/14