[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v16 04/13] s390x/pci: Avoid creating zpci for VFs
From: |
Akihiko Odaki |
Subject: |
[PATCH v16 04/13] s390x/pci: Avoid creating zpci for VFs |
Date: |
Fri, 13 Sep 2024 12:44:32 +0900 |
VFs are automatically created by PF, and creating zpci for them will
result in unexpected usage of fids. Currently QEMU does not support
multifunction for s390x so we don't need zpci for VFs anyway.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/s390x/s390-pci-bus.c | 19 +++++++++++++++++--
1 file changed, 17 insertions(+), 2 deletions(-)
diff --git a/hw/s390x/s390-pci-bus.c b/hw/s390x/s390-pci-bus.c
index 3e57d5faca18..1a620f5b2a04 100644
--- a/hw/s390x/s390-pci-bus.c
+++ b/hw/s390x/s390-pci-bus.c
@@ -1080,6 +1080,16 @@ static void s390_pcihost_plug(HotplugHandler
*hotplug_dev, DeviceState *dev,
pbdev = s390_pci_find_dev_by_target(s, dev->id);
if (!pbdev) {
+ /*
+ * VFs are automatically created by PF, and creating zpci for them
+ * will result in unexpected usage of fids. Currently QEMU does not
+ * support multifunction for s390x so we don't need zpci for VFs
+ * anyway.
+ */
+ if (pci_is_vf(pdev)) {
+ return;
+ }
+
pbdev = s390_pci_device_new(s, dev->id, errp);
if (!pbdev) {
return;
@@ -1167,7 +1177,9 @@ static void s390_pcihost_unplug(HotplugHandler
*hotplug_dev, DeviceState *dev,
int32_t devfn;
pbdev = s390_pci_find_dev_by_pci(s, PCI_DEVICE(dev));
- g_assert(pbdev);
+ if (!pbdev) {
+ return;
+ }
s390_pci_generate_plug_event(HP_EVENT_STANDBY_TO_RESERVED,
pbdev->fh, pbdev->fid);
@@ -1206,7 +1218,10 @@ static void s390_pcihost_unplug_request(HotplugHandler
*hotplug_dev,
* we've checked the PCI device already (to prevent endless recursion).
*/
pbdev = s390_pci_find_dev_by_pci(s, PCI_DEVICE(dev));
- g_assert(pbdev);
+ if (!pbdev) {
+ return;
+ }
+
pbdev->pci_unplug_request_processed = true;
qdev_unplug(DEVICE(pbdev), errp);
} else if (object_dynamic_cast(OBJECT(dev), TYPE_S390_PCI_DEVICE)) {
--
2.46.0
- [PATCH v16 00/13] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/09/12
- [PATCH v16 01/13] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/09/12
- [PATCH v16 02/13] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Akihiko Odaki, 2024/09/12
- [PATCH v16 03/13] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Akihiko Odaki, 2024/09/12
- [PATCH v16 04/13] s390x/pci: Avoid creating zpci for VFs,
Akihiko Odaki <=
- [PATCH v16 05/13] s390x/pci: Allow plugging SR-IOV devices, Akihiko Odaki, 2024/09/12
- [PATCH v16 06/13] s390x/pci: Check for multifunction after device realization, Akihiko Odaki, 2024/09/12
- [PATCH v16 07/13] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/09/12
- [PATCH v16 08/13] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/09/12
- [PATCH v16 09/13] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/09/12
- [PATCH v16 10/13] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/09/12
- [PATCH v16 11/13] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/09/12
- [PATCH v16 12/13] hw/pci: Use -1 as the default value for rombar, Akihiko Odaki, 2024/09/12