[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 17/19] Revert "hw/pci: Rename has_power to enabled"
From: |
Michael S. Tsirkin |
Subject: |
[PULL 17/19] Revert "hw/pci: Rename has_power to enabled" |
Date: |
Thu, 1 Aug 2024 06:37:06 -0400 |
This reverts commit 6a31b219a5338564f3978251c79f96f689e037da.
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
include/hw/pci/pci.h | 7 +------
include/hw/pci/pci_device.h | 2 +-
hw/pci/pci.c | 14 +++++++-------
hw/pci/pci_host.c | 4 ++--
4 files changed, 11 insertions(+), 16 deletions(-)
diff --git a/include/hw/pci/pci.h b/include/hw/pci/pci.h
index fe04b4fafd..eb26cac810 100644
--- a/include/hw/pci/pci.h
+++ b/include/hw/pci/pci.h
@@ -678,11 +678,6 @@ static inline void pci_irq_pulse(PCIDevice *pci_dev)
}
MSIMessage pci_get_msi_message(PCIDevice *dev, int vector);
-void pci_set_enabled(PCIDevice *pci_dev, bool state);
-
-static inline void pci_set_power(PCIDevice *pci_dev, bool state)
-{
- pci_set_enabled(pci_dev, state);
-}
+void pci_set_power(PCIDevice *pci_dev, bool state);
#endif
diff --git a/include/hw/pci/pci_device.h b/include/hw/pci/pci_device.h
index f38fb31119..15694f2489 100644
--- a/include/hw/pci/pci_device.h
+++ b/include/hw/pci/pci_device.h
@@ -57,7 +57,7 @@ typedef struct PCIReqIDCache PCIReqIDCache;
struct PCIDevice {
DeviceState qdev;
bool partially_hotplugged;
- bool enabled;
+ bool has_power;
/* PCI config space */
uint8_t *config;
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index b532888e8f..fab86d0567 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -1525,7 +1525,7 @@ static void pci_update_mappings(PCIDevice *d)
continue;
new_addr = pci_bar_address(d, i, r->type, r->size);
- if (!d->enabled) {
+ if (!d->has_power) {
new_addr = PCI_BAR_UNMAPPED;
}
@@ -1613,7 +1613,7 @@ void pci_default_write_config(PCIDevice *d, uint32_t
addr, uint32_t val_in, int
pci_update_irq_disabled(d, was_irq_disabled);
memory_region_set_enabled(&d->bus_master_enable_region,
(pci_get_word(d->config + PCI_COMMAND)
- & PCI_COMMAND_MASTER) && d->enabled);
+ & PCI_COMMAND_MASTER) && d->has_power);
}
msi_write_config(d, addr, val_in, l);
@@ -2884,18 +2884,18 @@ MSIMessage pci_get_msi_message(PCIDevice *dev, int
vector)
return msg;
}
-void pci_set_enabled(PCIDevice *d, bool state)
+void pci_set_power(PCIDevice *d, bool state)
{
- if (d->enabled == state) {
+ if (d->has_power == state) {
return;
}
- d->enabled = state;
+ d->has_power = state;
pci_update_mappings(d);
memory_region_set_enabled(&d->bus_master_enable_region,
(pci_get_word(d->config + PCI_COMMAND)
- & PCI_COMMAND_MASTER) && d->enabled);
- if (!d->enabled) {
+ & PCI_COMMAND_MASTER) && d->has_power);
+ if (!d->has_power) {
pci_device_reset(d);
}
}
diff --git a/hw/pci/pci_host.c b/hw/pci/pci_host.c
index 0d82727cc9..dfe6fe6184 100644
--- a/hw/pci/pci_host.c
+++ b/hw/pci/pci_host.c
@@ -86,7 +86,7 @@ void pci_host_config_write_common(PCIDevice *pci_dev,
uint32_t addr,
* allowing direct removal of unexposed functions.
*/
if ((pci_dev->qdev.hotplugged && !pci_get_function_0(pci_dev)) ||
- !pci_dev->enabled || is_pci_dev_ejected(pci_dev)) {
+ !pci_dev->has_power || is_pci_dev_ejected(pci_dev)) {
return;
}
@@ -111,7 +111,7 @@ uint32_t pci_host_config_read_common(PCIDevice *pci_dev,
uint32_t addr,
* allowing direct removal of unexposed functions.
*/
if ((pci_dev->qdev.hotplugged && !pci_get_function_0(pci_dev)) ||
- !pci_dev->enabled || is_pci_dev_ejected(pci_dev)) {
+ !pci_dev->has_power || is_pci_dev_ejected(pci_dev)) {
return ~0x0;
}
--
MST
- [PULL 07/19] Revert "pcie_sriov: Ensure PF and VF are mutually exclusive", (continued)
- [PULL 07/19] Revert "pcie_sriov: Ensure PF and VF are mutually exclusive", Michael S. Tsirkin, 2024/08/01
- [PULL 08/19] Revert "hw/pci: Fix SR-IOV VF number calculation", Michael S. Tsirkin, 2024/08/01
- [PULL 09/19] Revert "pcie_sriov: Register VFs after migration", Michael S. Tsirkin, 2024/08/01
- [PULL 10/19] Revert "pcie_sriov: Remove num_vfs from PCIESriovPF", Michael S. Tsirkin, 2024/08/01
- [PULL 11/19] Revert "pcie_sriov: Release VFs failed to realize", Michael S. Tsirkin, 2024/08/01
- [PULL 12/19] Revert "pcie_sriov: Reuse SR-IOV VF device instances", Michael S. Tsirkin, 2024/08/01
- [PULL 13/19] Revert "pcie_sriov: Ensure VF function number does not overflow", Michael S. Tsirkin, 2024/08/01
- [PULL 14/19] Revert "pcie_sriov: Do not manually unrealize", Michael S. Tsirkin, 2024/08/01
- [PULL 15/19] Revert "hw/ppc/spapr_pci: Do not reject VFs created after a PF", Michael S. Tsirkin, 2024/08/01
- [PULL 16/19] Revert "hw/ppc/spapr_pci: Do not create DT for disabled PCI device", Michael S. Tsirkin, 2024/08/01
- [PULL 17/19] Revert "hw/pci: Rename has_power to enabled",
Michael S. Tsirkin <=
- [PULL 18/19] hw/i386/amd_iommu: Don't leak memory in amdvi_update_iotlb(), Michael S. Tsirkin, 2024/08/01
- [PULL 19/19] intel_iommu: Fix for IQA reg read dropped DW field, Michael S. Tsirkin, 2024/08/01
- Re: [PULL 00/19] virtio,pci,pc: fixes, Richard Henderson, 2024/08/01