[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v10 03/12] hw/ppc/spapr_pci: Do not reject VFs created after a PF
From: |
Akihiko Odaki |
Subject: |
[PATCH v10 03/12] hw/ppc/spapr_pci: Do not reject VFs created after a PF |
Date: |
Thu, 27 Jun 2024 15:07:52 +0900 |
A PF may automatically create VFs and the PF may be function 0.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/ppc/spapr_pci.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/hw/ppc/spapr_pci.c b/hw/ppc/spapr_pci.c
index f63182a03c41..ed4454bbf79e 100644
--- a/hw/ppc/spapr_pci.c
+++ b/hw/ppc/spapr_pci.c
@@ -1573,7 +1573,9 @@ static void spapr_pci_pre_plug(HotplugHandler
*plug_handler,
* hotplug, we do not allow functions to be hotplugged to a
* slot that already has function 0 present
*/
- if (plugged_dev->hotplugged && bus->devices[PCI_DEVFN(slotnr, 0)] &&
+ if (plugged_dev->hotplugged &&
+ !pci_is_vf(pdev) &&
+ bus->devices[PCI_DEVFN(slotnr, 0)] &&
PCI_FUNC(pdev->devfn) != 0) {
error_setg(errp, "PCI: slot %d function 0 already occupied by %s,"
" additional functions can no longer be exposed to guest.",
--
2.45.2
- [PATCH v10 00/12] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/06/27
- [PATCH v10 01/12] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/06/27
- [PATCH v10 02/12] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Akihiko Odaki, 2024/06/27
- [PATCH v10 03/12] hw/ppc/spapr_pci: Do not reject VFs created after a PF,
Akihiko Odaki <=
- [PATCH v10 04/12] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/06/27
- [PATCH v10 05/12] pcie_sriov: Ensure VF function number does not overflow, Akihiko Odaki, 2024/06/27
- [PATCH v10 06/12] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/06/27
- [PATCH v10 07/12] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/06/27
- [PATCH v10 08/12] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/06/27
- [PATCH v10 09/12] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/06/27
- [PATCH v10 10/12] hw/pci: Replace -1 with UINT32_MAX for romsize, Akihiko Odaki, 2024/06/27
- [PATCH v10 11/12] hw/pci: Convert rom_bar into OnOffAuto, Akihiko Odaki, 2024/06/27
- [PATCH v10 12/12] hw/qdev: Remove opts member, Akihiko Odaki, 2024/06/27