[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 1/2] qom/object_interfaces: Remove unnecessary local_err chec
From: |
Zhao Liu |
Subject: |
Re: [PATCH 1/2] qom/object_interfaces: Remove unnecessary local_err check |
Date: |
Fri, 15 Mar 2024 16:20:07 +0800 |
On Thu, Feb 29, 2024 at 11:37:38AM +0800, Zhenzhong Duan wrote:
> Date: Thu, 29 Feb 2024 11:37:38 +0800
> From: Zhenzhong Duan <zhenzhong.duan@intel.com>
> Subject: [PATCH 1/2] qom/object_interfaces: Remove unnecessary local_err
> check
> X-Mailer: git-send-email 2.34.1
>
> In the error return path, local_err is always set, no need to check it.
The original error handling code indicates "local_err is always set",
and error_propagate() can handle the case that local_err is NULL.
> Signed-off-by: Zhenzhong Duan <zhenzhong.duan@intel.com>
> ---
> qom/object_interfaces.c | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/qom/object_interfaces.c b/qom/object_interfaces.c
> index e0833c8bfe..255a7bf659 100644
> --- a/qom/object_interfaces.c
> +++ b/qom/object_interfaces.c
> @@ -128,13 +128,11 @@ Object *user_creatable_add_type(const char *type, const
> char *id,
> }
> goto out;
> }
> -out:
> - if (local_err) {
> - error_propagate(errp, local_err);
> - object_unref(obj);
> - return NULL;
> - }
> return obj;
> +out:
Maybe rename this to "err:"? Since now it's just used to handle error,
and "goto err" seems more clear.
> + error_propagate(errp, local_err);
> + object_unref(obj);
> + return NULL;
> }
>
> void user_creatable_add_qapi(ObjectOptions *options, Error **errp)
> --
> 2.34.1
>
Otherwise,
Reviewed-by: Zhao Liu <zhao1.liu@intel.com>
- Re: [PATCH 1/2] qom/object_interfaces: Remove unnecessary local_err check,
Zhao Liu <=