[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 20/56] hw/rx/rx62n: Reduce inclusion of 'qemu/units.h'
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 20/56] hw/rx/rx62n: Reduce inclusion of 'qemu/units.h' |
Date: |
Thu, 15 Feb 2024 18:57:14 +0100 |
"qemu/units.h" is not used in the "hw/rx/rx62n.h"
header, include it in the source where it is.
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Yoshinori Sato <ysato@users.sourceforge.jp>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Message-Id: <20240213130341.1793-3-philmd@linaro.org>
---
include/hw/rx/rx62n.h | 1 -
hw/rx/rx-gdbsim.c | 1 +
hw/rx/rx62n.c | 1 +
3 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/include/hw/rx/rx62n.h b/include/hw/rx/rx62n.h
index 73ceeb58e5..bcda583ab3 100644
--- a/include/hw/rx/rx62n.h
+++ b/include/hw/rx/rx62n.h
@@ -29,7 +29,6 @@
#include "hw/timer/renesas_tmr.h"
#include "hw/timer/renesas_cmt.h"
#include "hw/char/renesas_sci.h"
-#include "qemu/units.h"
#include "qom/object.h"
#define TYPE_RX62N_MCU "rx62n-mcu"
diff --git a/hw/rx/rx-gdbsim.c b/hw/rx/rx-gdbsim.c
index 47c17026c7..bb4746c556 100644
--- a/hw/rx/rx-gdbsim.c
+++ b/hw/rx/rx-gdbsim.c
@@ -20,6 +20,7 @@
#include "qemu/cutils.h"
#include "qemu/error-report.h"
#include "qemu/guest-random.h"
+#include "qemu/units.h"
#include "qapi/error.h"
#include "hw/loader.h"
#include "hw/rx/rx62n.h"
diff --git a/hw/rx/rx62n.c b/hw/rx/rx62n.c
index 4dc44afd9d..d3f61a6837 100644
--- a/hw/rx/rx62n.c
+++ b/hw/rx/rx62n.c
@@ -23,6 +23,7 @@
#include "qemu/osdep.h"
#include "qapi/error.h"
#include "qemu/error-report.h"
+#include "qemu/units.h"
#include "hw/rx/rx62n.h"
#include "hw/loader.h"
#include "hw/sysbus.h"
--
2.41.0
- [PULL 10/56] target/mips: Remove unused mips_def_t::SAARP field, (continued)
- [PULL 10/56] target/mips: Remove unused mips_def_t::SAARP field, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 11/56] target/mips: Remove CPUMIPSState::CP0_SAAR[2] field, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 12/56] target/mips: Remove helpers accessing SAARI register, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 16/56] hw/mips/Kconfig: Remove ISA dependencies from MIPSsim board, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 13/56] target/mips: Remove CPUMIPSState::CP0_SAARI field, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 15/56] hw/isa: clean up Kconfig selections for ISA_SUPERIO, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 17/56] hw/isa: fix ISA_SUPERIO dependencies, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 14/56] target/mips: Remove the unused DisasContext::saar field, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 18/56] hw/isa: specify instance_size in isa_superio_type_info, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 19/56] hw/isa: extract FDC37M81X to a separate file, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 20/56] hw/rx/rx62n: Reduce inclusion of 'qemu/units.h',
Philippe Mathieu-Daudé <=
- [PULL 22/56] hw/i386/q35: Realize LPC PCI function before accessing it, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 21/56] hw/rx/rx62n: Only call qdev_get_gpio_in() when necessary, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 24/56] hw/misc/macio: Realize IDE controller before accessing it, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 25/56] hw/sh4/r2d: Realize IDE controller before accessing it, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 23/56] hw/ppc/prep: Realize ISA bridge before accessing it, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 26/56] hw/dma: Pass parent object to i8257_dma_init(), Philippe Mathieu-Daudé, 2024/02/15
- [PULL 27/56] hw/sparc/sun4m: Realize DMA controller before accessing it, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 28/56] hw/sparc64/cpu: Initialize GPIO before realizing CPU devices, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 29/56] target/sparc: Provide hint about CPUSPARCState::irq_manager member, Philippe Mathieu-Daudé, 2024/02/15
- [PULL 30/56] hw/sparc/leon3: Remove duplicate code, Philippe Mathieu-Daudé, 2024/02/15