[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 17/31] tcg: Make tb_cflags() usable from target-agnostic code
From: |
Richard Henderson |
Subject: |
[PULL 17/31] tcg: Make tb_cflags() usable from target-agnostic code |
Date: |
Tue, 30 Jan 2024 09:01:07 +1000 |
From: Ilya Leoshkevich <iii@linux.ibm.com>
Currently tb_cflags() is defined in exec-all.h, which is not usable
from target-agnostic code. Move it to translation-block.h, which is.
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Signed-off-by: Ilya Leoshkevich <iii@linux.ibm.com>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Message-ID: <20231212003837.64090-3-iii@linux.ibm.com>
Message-Id: <20240125054631.78867-3-philmd@linaro.org>
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
include/exec/exec-all.h | 6 ------
include/exec/translation-block.h | 6 ++++++
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/exec/exec-all.h b/include/exec/exec-all.h
index df3d93a2e2..ce36bb10d4 100644
--- a/include/exec/exec-all.h
+++ b/include/exec/exec-all.h
@@ -459,12 +459,6 @@ int probe_access_full_mmu(CPUArchState *env, vaddr addr,
int size,
#endif
-/* Hide the qatomic_read to make code a little easier on the eyes */
-static inline uint32_t tb_cflags(const TranslationBlock *tb)
-{
- return qatomic_read(&tb->cflags);
-}
-
static inline tb_page_addr_t tb_page_addr0(const TranslationBlock *tb)
{
#ifdef CONFIG_USER_ONLY
diff --git a/include/exec/translation-block.h b/include/exec/translation-block.h
index e2b26e16da..48211c890a 100644
--- a/include/exec/translation-block.h
+++ b/include/exec/translation-block.h
@@ -145,4 +145,10 @@ struct TranslationBlock {
/* The alignment given to TranslationBlock during allocation. */
#define CODE_GEN_ALIGN 16
+/* Hide the qatomic_read to make code a little easier on the eyes */
+static inline uint32_t tb_cflags(const TranslationBlock *tb)
+{
+ return qatomic_read(&tb->cflags);
+}
+
#endif /* EXEC_TRANSLATION_BLOCK_H */
--
2.34.1
- [PULL 08/31] include/exec: Move cpu_*()/cpu_env() to common header, (continued)
- [PULL 08/31] include/exec: Move cpu_*()/cpu_env() to common header, Richard Henderson, 2024/01/29
- [PULL 05/31] include/exec: Use vaddr in DisasContextBase for virtual addresses, Richard Henderson, 2024/01/29
- [PULL 09/31] include/hw/core: Move do_interrupt in TCGCPUOps, Richard Henderson, 2024/01/29
- [PULL 10/31] include/hw/core: Remove i386 conditional on fake_user_interrupt, Richard Henderson, 2024/01/29
- [PULL 12/31] tests/tcg: Factor out gdbstub test functions, Richard Henderson, 2024/01/29
- [PULL 13/31] tests/tcg: Add the PROT_NONE gdbstub test, Richard Henderson, 2024/01/29
- [PULL 11/31] linux-user: Allow gdbstub to ignore page protection, Richard Henderson, 2024/01/29
- [PULL 14/31] accel/tcg/cpu-exec: Use RCU_READ_LOCK_GUARD, Richard Henderson, 2024/01/29
- [PULL 15/31] target: Make qemu_target_page_mask() available for *-user, Richard Henderson, 2024/01/29
- [PULL 16/31] accel/tcg: Make use of qemu_target_page_mask() in perf.c, Richard Henderson, 2024/01/29
- [PULL 17/31] tcg: Make tb_cflags() usable from target-agnostic code,
Richard Henderson <=
- [PULL 19/31] accel/tcg: Move perf and debuginfo support to tcg/, Richard Henderson, 2024/01/29
- [PULL 21/31] accel/tcg: Rename tcg_cpus_destroy() -> tcg_cpu_destroy(), Richard Henderson, 2024/01/29
- [PULL 18/31] accel/tcg: Remove #ifdef TARGET_I386 from perf.c, Richard Henderson, 2024/01/29
- [PULL 20/31] accel/tcg: Rename tcg_ss[] -> tcg_specific_ss[] in meson, Richard Henderson, 2024/01/29
- [PULL 25/31] target/loongarch: Constify loongarch_tcg_ops, Richard Henderson, 2024/01/29
- [PULL 28/31] target/i386: Extract x86_need_replay_interrupt() from accel/tcg/, Richard Henderson, 2024/01/29
- [PULL 22/31] accel/tcg: Rename tcg_cpus_exec() -> tcg_cpu_exec(), Richard Henderson, 2024/01/29
- [PULL 29/31] accel/tcg: Inline need_replay_interrupt, Richard Henderson, 2024/01/29
- [PULL 24/31] include/qemu: Add TCGCPUOps typedef to typedefs.h, Richard Henderson, 2024/01/29
- [PULL 23/31] accel/tcg: Un-inline icount_exit_request() for clarity, Richard Henderson, 2024/01/29