[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 19/33] tcg: Make tb_cflags() usable from target-agnostic code
From: |
Richard Henderson |
Subject: |
[PATCH 19/33] tcg: Make tb_cflags() usable from target-agnostic code |
Date: |
Sun, 28 Jan 2024 14:41:59 +1000 |
From: Ilya Leoshkevich <iii@linux.ibm.com>
Currently tb_cflags() is defined in exec-all.h, which is not usable
from target-agnostic code. Move it to translation-block.h, which is.
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Signed-off-by: Ilya Leoshkevich <iii@linux.ibm.com>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Message-ID: <20231212003837.64090-3-iii@linux.ibm.com>
Message-Id: <20240125054631.78867-3-philmd@linaro.org>
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
include/exec/exec-all.h | 6 ------
include/exec/translation-block.h | 6 ++++++
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/exec/exec-all.h b/include/exec/exec-all.h
index df3d93a2e2..ce36bb10d4 100644
--- a/include/exec/exec-all.h
+++ b/include/exec/exec-all.h
@@ -459,12 +459,6 @@ int probe_access_full_mmu(CPUArchState *env, vaddr addr,
int size,
#endif
-/* Hide the qatomic_read to make code a little easier on the eyes */
-static inline uint32_t tb_cflags(const TranslationBlock *tb)
-{
- return qatomic_read(&tb->cflags);
-}
-
static inline tb_page_addr_t tb_page_addr0(const TranslationBlock *tb)
{
#ifdef CONFIG_USER_ONLY
diff --git a/include/exec/translation-block.h b/include/exec/translation-block.h
index e2b26e16da..48211c890a 100644
--- a/include/exec/translation-block.h
+++ b/include/exec/translation-block.h
@@ -145,4 +145,10 @@ struct TranslationBlock {
/* The alignment given to TranslationBlock during allocation. */
#define CODE_GEN_ALIGN 16
+/* Hide the qatomic_read to make code a little easier on the eyes */
+static inline uint32_t tb_cflags(const TranslationBlock *tb)
+{
+ return qatomic_read(&tb->cflags);
+}
+
#endif /* EXEC_TRANSLATION_BLOCK_H */
--
2.34.1
- Re: [PATCH 10/33] include/exec: Move cpu_*()/cpu_env() to common header, (continued)
- [PATCH 11/33] include/hw/core: Move do_interrupt in TCGCPUOps, Richard Henderson, 2024/01/27
- [PATCH 12/33] include/hw/core: Remove i386 conditional on fake_user_interrupt, Richard Henderson, 2024/01/27
- [PATCH 13/33] linux-user: Allow gdbstub to ignore page protection, Richard Henderson, 2024/01/27
- [PATCH 14/33] tests/tcg: Factor out gdbstub test functions, Richard Henderson, 2024/01/27
- [PATCH 15/33] tests/tcg: Add the PROT_NONE gdbstub test, Richard Henderson, 2024/01/27
- [PATCH 16/33] accel/tcg/cpu-exec: Use RCU_READ_LOCK_GUARD, Richard Henderson, 2024/01/27
- [PATCH 17/33] target: Make qemu_target_page_mask() available for *-user, Richard Henderson, 2024/01/27
- [PATCH 18/33] accel/tcg: Make use of qemu_target_page_mask() in perf.c, Richard Henderson, 2024/01/27
- [PATCH 19/33] tcg: Make tb_cflags() usable from target-agnostic code,
Richard Henderson <=
- [PATCH 20/33] accel/tcg: Remove #ifdef TARGET_I386 from perf.c, Richard Henderson, 2024/01/27
- [PATCH 21/33] accel/tcg: Move perf and debuginfo support to tcg/, Richard Henderson, 2024/01/27
- [PATCH 22/33] accel/tcg: Rename tcg_ss[] -> tcg_specific_ss[] in meson, Richard Henderson, 2024/01/27
- [PATCH 23/33] accel/tcg: Rename tcg_cpus_destroy() -> tcg_cpu_destroy(), Richard Henderson, 2024/01/27
- [PATCH 24/33] accel/tcg: Rename tcg_cpus_exec() -> tcg_cpu_exec(), Richard Henderson, 2024/01/27
- [PATCH 25/33] accel/tcg: Un-inline icount_exit_request() for clarity, Richard Henderson, 2024/01/27
- [PATCH 26/33] include/qemu: Add TCGCPUOps typedef to typedefs.h, Richard Henderson, 2024/01/27
- [PATCH 27/33] target/loongarch: Constify loongarch_tcg_ops, Richard Henderson, 2024/01/27
- [PATCH 28/33] accel/tcg: Use CPUState.cc instead of CPU_GET_CLASS in cpu-exec.c, Richard Henderson, 2024/01/27