[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 1/6] device_tree: add qemu_fdt_setprop_strings() helper
From: |
Andrew Jones |
Subject: |
Re: [PATCH v5 1/6] device_tree: add qemu_fdt_setprop_strings() helper |
Date: |
Fri, 21 Oct 2022 08:56:18 +0200 |
On Fri, Oct 21, 2022 at 06:58:03AM +0100, Ben Dooks wrote:
> Add a helper to set a property from a set of strings
> to reduce the following code:
>
> static const char * const clint_compat[2] = {
> "sifive,clint0", "riscv,clint0"
> };
>
> qemu_fdt_setprop_string_array(fdt, nodename, "compatible",
> (char **)&clint_compat, ARRAY_SIZE(clint_compat));
>
> Signed-off-by: Ben Dooks <qemu@ben.fluff.org>
> ---
> v4:
> - go back to the non-return call, no-one is using the result
> v3;
> - fix return value for the call
> - add better help text
> v2:
> - fix node/path in comment
> ---
> include/sysemu/device_tree.h | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)
>
> diff --git a/include/sysemu/device_tree.h b/include/sysemu/device_tree.h
> index e7c5441f56..cb49df471b 100644
> --- a/include/sysemu/device_tree.h
> +++ b/include/sysemu/device_tree.h
> @@ -87,6 +87,25 @@ int qemu_fdt_setprop_string(void *fdt, const char
> *node_path,
> int qemu_fdt_setprop_string_array(void *fdt, const char *node_path,
> const char *prop, char **array, int len);
>
> +/**
> + * qemu_fdt_setprop_strings: set a property from a set of strings
> + *
> + * @fdt: pointer to the dt blob
> + * @path: node name
> + * @prop: property array
> + *
> + * This is a helper for the qemu_fdt_setprop_string_array() function
> + * which takes a va-arg set of strings instead of having to setup a
> + * single use string array.
> + */
> +#define qemu_fdt_setprop_strings(fdt, path, prop, ...) \
> + do { \
> + static const char * const __strs[] = { __VA_ARGS__ }; \
> + qemu_fdt_setprop_string_array(fdt, path, prop, \
> + (char **)&__strs, ARRAY_SIZE(__strs)); \
> + } while(0)
> +
> +
I made several comments on v4 of this that aren't addressed.
> int qemu_fdt_setprop_phandle(void *fdt, const char *node_path,
> const char *property,
> const char *target_node_path);
> --
> 2.35.1
>
>
- add qemu_fdt_setprop_strings, Ben Dooks, 2022/10/21
- [PATCH v5 1/6] device_tree: add qemu_fdt_setprop_strings() helper, Ben Dooks, 2022/10/21
- Re: [PATCH v5 1/6] device_tree: add qemu_fdt_setprop_strings() helper,
Andrew Jones <=
- [PATCH v5 5/6] hw/mips: use qemu_fdt_setprop_strings(), Ben Dooks, 2022/10/21
- [PATCH v5 6/6] hw/arm: change to use qemu_fdt_setprop_strings(), Ben Dooks, 2022/10/21
- [PATCH v5 4/6] hw/core: use qemu_fdt_setprop_strings(), Ben Dooks, 2022/10/21
- [PATCH v5 2/6] hw/core: don't check return on qemu_fdt_setprop_string_array(), Ben Dooks, 2022/10/21
- [PATCH v5 3/6] hw/riscv: use qemu_fdt_setprop_strings() for string arrays, Ben Dooks, 2022/10/21
- Re: add qemu_fdt_setprop_strings, Andrew Jones, 2022/10/21